Pairing of Bosch Smart Plug EU BSP-FZ2 not possible

Hi all,

for some time I am now successfully using Raspberry Pi 4 + ConBee II + Phoscon App to very basically control some devices. (e.g. Aqara Smart Plug EU)

Today I purchased the Bosch Smart Plug EU BSP-FZ2 and tried to pair it using Phoscon App but this is not working.
I tried it several times and as different devices (but mainly as light which should be correct).
In the beginning I was not sure whether it is supported at all but according to is should be supported since v2.21.0 #6689.

Do you have any ideas how I can get it working?

It is my first time active in Phoscon Community, so I am not sure which kind of data you need, but here some information from the Phoscon App:
Product: ConBee II
Version: 2.22.02 / 19.9.2022
Firmware: 26780700

Let me know if you need something else. :wink:

Best regards

You need to use the install code.

Shows how to do it with the api.

Thanks for the quick answer! That totally makes sense with install code and the Bosch device.

As I have almost only worked withh GUI based pairing and control using deCONZ/Phoscon and iobroker.
I will have a look at API and how to use it and give feedback.

REST-API is working now for me using Google Chrome Postman and commands can be send successfully.
For instance
GET /api/<api-key>/devices
returns 3 addresses (UIDs), one is the Gateways, other two are my already two connected devices, so that’s fine.

Looking at the backside / 2D-Code of the Bosch Smart Plug I can find the UID (EUI-64) and the Install Code. This UID is of course not listed in the above 3 UIDs.
When issuing the PUT command mentioned in your linked post using the UID + Install Code, I get an error like “body contains invalid JSON”.
When issuing just a GET command but just without the /installcode at the end, I get nothing at all.
When issuing the same GET command but to a UID of already connected Aqara device, I get a lot of information about the device.

I got stuck here and your mentioned post gives me no further information.
What would be the next required steps?

Unfortunately, the deCONZ REST-API does not provide any documentation about usage of /devices/ if I see it correctly.

There’s some samples on GitHub. Also in the referred issue in that pr I linked

I asked the devs to reply here with documentation, but I recommend reading the GitHub as it is faster.

The API is telling you already that your request is incorrect. Please ensure that you include valid JSON in your request and try again.

Indeed, the devices endpoint should get its own documentation area. As far as I know, it was more experimental back in the days and therefore, not considered. This changed more and more recently.

From my understand PUT should work if resource / device is already existing but like mentioned, the device is not existing at all by now. So for me it makes sense that PUT on the not existing UID is not working.
Is any POST necessary before proceeding with PR #6791?
Do I need to create something using plug_compact.json at first and then adding install code?

Sorry for asking, maybe there is somewhere a description linked to the PR which I cannot find…

Update: Finally its working now! :slight_smile:

I just have seen that the deCONZ REST-API documentation has been updated: Devices - deCONZ REST-API
An important hint there is

URL must be provided without colons

I just retried everything step by step and using raw JSON format instead of Postman’s form-data and voilà, now it worked.

What I did step by step:

  1. Use PUT command as mentioned in PR, response as expected with success, install code and mmohash
  2. Opening Phoscon Webapp and started searching for new Light
  3. Press Power-Button on Bosch Plug and plugged into mains plug
  4. Pairing in Phoscon Webapp after some seconds successful

Seems my undertanding of PUT is not working without existing resource was not correct.

Thank you very much for your great support. Hopefully, this maybe also help others.


The documentation was created on my request. Happy to see it’s working!

Did someone succeed integrating the Bosch Smart Plug EU? I could send the install code via REST. Also deCONZ found the plug and visualized it, however as a dumb device not identifying any model or function. So it just sits there, but you cannot do anything with it.

As mentioned in my previous comment, in my setup (RPi 4 + ConBee II + deCONZ/Phoscon used in ioBroker running on RPi) it worked and still works. I can use the Bosch Smart Plug, switch on/off, read consumption, …
After pairing in Phoscon Webapp everything was working in ioBroker on-the-fly.

It worked now. I was on latest beta software, which was unstable and rebooted when I wanted to pair. So I went back to stable channel and voila it worked.

Regards, Maik.