[OpenHAB] SmartHome/J Deconz Binding

You can place feature requests, bug reports or questions regarding the deconz binding and the integration of deconz with openHAB using that binding here. I‘ll try to answer ASAP.

Added OpenHAB tag in the bar for clarity :slight_smile:

Hello @J-N-K ,
I run a couple of zigbee plugs from Osram/Ledvance. They are connected via a Conbee2-Zigbee-Stick and Phoscon software.

Integration in OpenHAB is done via the deconz binding.
Everything is running fine, but today I wanted to integrate another plug in OpenHAB, but I failed, since there are no channels to link to.

All the existing plug-items were created in OH 3.0, now I am on OH 3.2.

Channels for other things connected via deconz, like brightness sensors or ikea tradfri remote, are shown in OpenHAB. Just the plugs do not show any channels.

Is there a way how to add a new plug item without channels being visible?
Any help appreciated!

I also created a thread in the OpenHAB forums that also shows some screenshots:

At some point (I do not remember exactly when, I believe between 3.0 and 3.1) the channel-types changed. That‘s a very unfortunate decision within openHAB, because there is no way to upgrade existing things (beside deleting and re-adding them). IMO you encounter that issue.

Newly added things should not be affected.

Since you are on openHAB 3.2, you can try my own version:

  • uninstall the openHAB deconz binding
  • add https://download.smarthomej.org/addons.json as „3rd Party JSON Add-On Service“ (or similar, depends on your language settings)
  • install the „SmartHome/J Deconz Binding“

Please let me know if that helps.

1 Like

Thank you for the quick response.
I added things for all my Plugs with OH 3.0, but only created items for the ones currently in use.
So the one that I wanted to add now, already had an existing thing in OH, but no item.

I deleted the thing and readded it, et voila, now I have channels! :slight_smile:

Thank you very much!!!

1 Like

Hello Jan,

I would like to submit a feature request. Since a few days I have a soil moisture sensor
Manufacturer: modkam.ru
Product: DIYRuZ_Flower
In the meantime I was able to read and integrate it into deconz.

Here is the tip how to do it:
Only briefly to the documentation, if someone else should have the same problem like me: in the Phoscon forum the tip came to wake up the sensor over the key while one clicks “read attributes” in “cluster info”. With this, the measured value for ZHAMoisture was “taken over” and I can access it via the API.

Now comes my question and request:
Is it possible to include the resourcetype “ZHAMoisture” in the bindung so that you can use it in OpenHAB3?

Example data
“config”: {
“battery”: 100,
“on”: true,
“reachable”: true
“ep”: 1,
}, “etag”: “xxxxxxxx”,
“lastannounced”: “2022-09-03T14:19:55Z”,
“lastseen”: “2022-09-03T15:05Z”,
“manufacturername”: “modkam.ru”,
“modelid”: “DIYRuZ_Flower”,
}, “name”: “soil moisture beds”,
“state”: {
“lastupdated”: “2022-09-03T15:05:18.181”,
“moisture”: 5
}, “swversion”: “22/07/2021 10:04”,
“type”: “ZHAMoisture”,
“uniqueid”: “00:00:00:00:00:00:00:00-01-0408”

This should already be part of the latest SmartHome/J release of the deconz binding for openHAB. If you use an older version, it depends on the installation method how you upgrade.

Hi Jan, thanks for the quick reply. I am using the Openhab 3.3 version and the binding also shows the 3.3.0 version. This is the latest version as far as I know. However, there is nothing in the description of ZHAMoisture. In which version should the extension be found and can I install it manually in Docker?

Have a look here: [OpenHAB] SmartHome/J Deconz Binding - #4 by J-N-K The original binding does not support it.

Hello Jan,

thank you very much for the tip.
I have read about this site before and downloaded from there the “SmartHome/J TCP/UDP Binding” and tried to get it to work with my T25, unfortunately this did not work even after many tests of several days and I then turned to another solution. As I understood it, it is not the original Deconz Binding. Is there a chance to see your extensions at some point in the original binding or will that work in the future only with your version?

Hello Jan, I have integrated the 3rd party deconz and can now read the sensors, thank you very much for that. Do you have a tip for me regarding the TcpUdp binding (also gladly in another channel) for me.

Hello Jan,

this time not in German :slight_smile:
Unfortunately I still have problems with receiving the Moisture Sensor Messages continuously.

DECONZ Auszug:
Hersteller modkam.ru
Produkt DIYRuZ_Flower
Version 22/07/2021 10:04
Batterie 100 %
Lichtniveau 0 Lux
Luftdruck 0 hPa
Temperatur 0 °C
Luftfeuchtigkeit 0 %
Aktualisiert 13.09.2022 02:24:34 vor einer Minute

However, the read in values in OpenHAB3 are still from 01:05 instead of 02:24 and do not seem to be updated.

When I go into the channel details and press refresh in the browser I only get:

Requested content not found.
Debug information

  • Url: /settings/things/deconz:moisturesensor:tt:Sensor_Garten_Test_Moisture/links/Sensor_Garten_Test_LastUpdated/last_updated
  • Path: /settings/things/deconz:moisturesensor:tt:Sensor_Garten_Test_Moisture/links/Sensor_Garten_Test_LastUpdated/last_updated
  • Hash:

Maybe you have another idea what this could be?

Hi, can you please translate to English as we are an English forum? Thanks :slight_smile:

Hello Jan, the system is now running for a few days and so I would like to give feedback. I have now “added” all sensors again without deleting them. Afterwards I have read in all “Cluster Info” values over the VNC surface again. now the values are identical in the Deconz, Phoscon and API. Likewise, the initial “null” values have disappeared, here is now a time and each correctly “0” displayed. I will now observe a few days, whether the system now runs stable and give feedback again. At this point, first of all, thank you for all the hints and tips from you.

Hello Jan, here is my announced feedback. The last weeks I got some new insights about the “DIYRuZ_Flower” sensors, which I would like to share here.

“manufacturername”: “modkam.ru”,
“modelid”: “DIYRuZ_Flower”.

  1. all values you can read out except the installed moinsture sensors are always zero/0
  2. if zigbee lamps are removed, the path to the gateway is forgotten and the sensor no longer provides data. The rehang did not work for me.
  3. for this reason, sensors should always be taught and integrated in the place intended for them.
  4. sensors that are no longer recognized and no longer transmit, can simply be reset by pressing the button for 10 seconds and relearned. Sometimes, if this does not work, it also helps to simply remove the battery for 3 seconds.
  5. the sensors sometimes provide a current last seen date, but no current value, then you should perform point 4 again.

Basically you can say that the “DIYRuZ_Flower” sensors, if they are learned correctly and no lamps (Hops) are removed in the network, work well and reliably with a deconz conbee II stick. If problems occur, then you must unfortunately always relearn them, but this should only happen when changes in the zigbee network (removal of components).

If it works fine until you change something in the network, then the issue is not in the openHAB integration but somewhere deeper in deconz. OpenHAB knows nothing about the network wiring.

This is also seen with Xiaomi devices and is due to the Firmware of the device. Nothing to be done on deCONZ or other software side.

Hi Jan, I tried your version but still, the sensors that are visible in the Phoscon App do not show up in openHAB. The deCONZ service is running fine on its own port (8070).

BTW, where do I find the deCONZ logs?

What type of sensors are they? Can you post the REST API response?