No HomeBridge Pin code

I’ve installed a fresh RPi image Phoscon_Gateway_Homebridge_2021-07-05

There is no pin code listed for homebridge. Ive tried resetting homebridge (reset button), rebooting, etc. Ideas?

I think I have a pattern - please confirm so we can escalate this to a bug if correct.

  1. use a Phoscon-supplied SD card image which DOES NOT have homebridge support, and take backup of your gateway configuration.
  2. overwrite your SD card with a Phoscon-supplied SD card image which DOES have homebridge support.
  3. Boot the pi, note that you will see a HomeBridge PIN code.
  4. Restore the backup of your configuration

** you now see that a HomeBridge PIN code is not available **

Actually… I’ve just done a fresh install of Phoscon GW + Homebridge, and immediately it came up without a pin available.

Aha! Another variation!
I did another clean install of Phoscon_Gateway_Homebridge_2021-07-05.xz and I got a pin code.
However, after rebooting I just get “Homebridge is currently being installed” shown on the Advanced Settings screen.
Waiting for several minutes, and that message doesnt go away. Note: it was not set to auto-update Homebridge…

Why so many different behaviors?

Moving from Phoscon App - General Support to Phoscon App - Bug Reports

When Homebridge could be installed with the Phoscon Homebridge Image once it should also work next time. But installation will take a few minutes after the RPI boots and internet connection is mandatory and also that the RPI has correct date and time.

So does it install Homebridge now?

I would not exclude that it really is a bug related to the backup. If it still shows no pin could you check your homebridge configuration file (~/.homebridge/config.json) if there is a key.