New Tuya Smart Plug: NAS-WR01B or _TZ3000_w0qqde0g

Just borrowed 1pcs to friend with different tuya bridge and it worked…so seems that my bridge may be some kind “broken” (tried different wlans/psu/reset/reconfigure)
The plug itself seems to be one of the best in case price/quality. Works nice as router and after fw upgrade reports usage in seconds instead of pooling!

Can you please provide a link to the bridge you bought?
On Ali I was unable to find a Tuya bridge with the type LQ-W1 or dimensions of 7x7x1.2cm.

I want to buy a bridge also to be able to update my Tuya plugs

It no longer exists, but I would just take the risk and order one for $15. :slight_smile:

Any Tuya powered bridge should be OK - my 1st bridge was probably “broken” I’ve ordered new bridge with LAN connectivity and was able to update 3pcs of this plug without problem.

Would you mind testing on 2.14 with a few plugs? I have been struggling a lot over the last few weeks in combination with DDF (inclusing the built-in “Silver” DDF):

I am really curious to know if others are also having issues!

Well, currently I’m on 2.13.4 (official deconz addon to HA) and added manually DDF (for this neo plugs) to container. I was afraid that it will couse same issue as you described but since yesterday when i’ve joined updated 3 pcs neo power plugs, deconz still works ok. The other power plugs are Blitzwolf BW-SHP13.
In my case to test 2.14 beta i may require some changes in my stable environment :slight_smile:

Mmmm… I was already having issues on 2.13.4 as well. Did you use the “Silver” NEO Plug DDF that is in the deconz repo, or did you create your own? And do they report properly, no delays or issues? Did you also try to “Hot reload” in DDF Edit mode for the NEO plug?

I think the SHP13’s are not using DDF yet (they are polling only). My issue might be related to my 5 existing SHP15 plugs, who somehow seem to be loading/using the same NEO DDF, even though they have a different manufacturer name. I am still trying to find out how this is officially supposed to work. :frowning:

BTW: As described, fallback is relatively easy: restore a working database.

1 Like


I want to share my experience with these plugs.

I bought 3 orange plugs from Aliexpress:

While waiting for them, I found this thread and @iisworks comments that there is a new Firmware for these plugs and you also need a Tuya Hub to make the update. So I did order Tuya hub from here: and I successfully managed to upgrade plugs with new Firmware(1.0.10).

Next, I added these plugs to deCONZ through Phoscon App web interface(Home Assistant deCONZ addon). I could only control On/Off state from Home Assistant, no Power and Consumption Measurement sensors were added. Manufacturer for these plugs is _TZ3000_gjnozsaz.

To make Power and Consumption sensors available and updating in Home Assistant, I did this:

  1. Created new NAS-WR01B_2.json file inside directory /usr/share/hassio/addons/data/core_deconz/.local/share/dresden-elektronik/deCONZ/devices/neo/ (neo directory didn’t exist, so I created it by myself)
  2. To NAS-WR01B_2.json file inserted DDF, mentioned in #62 comment by @Smanar (sorry I can’t add more links because of new user policy)
  3. Inside file replaced:
    • manufacturername to _TZ3000_gjnozsaz
    • status to Gold
    • path to /devices/neo/NAS-WR01B_2.json
  4. Restarted deCONZ Addon
  5. Restarted Home Assistant (somehow Measurement sensors didn’t want to update their state/attributes until I restarted)

Now I have 3 relatively cheap smart plugs that reports power measurement data.

1 Like

There is a bug in 2.14.1 that allows you to use any TS011F plug with the built-in NEO DDF (DDF needs to be in Silver mode during pairing):

But I’m very curious to know: are you experiencing any slowness/delays in deconz with these plugs on the new Tuya FW connected?

But I’m very curious to know: are you experiencing any slowness/delays in deconz with these plugs on the new Tuya FW connected?

I didn’t notice any issues so far. Everything is quick as before plugs were connected.

Thanks, good to know! Do yo have devices connected that change Power consumption a lot, e.g. a PC (W changes every second)? Or just devices with a more stable load like a light?

I use one plug for TV which is always in On state, and other two are Off unless I turn them on(for charging my wall tablet or power on radio).

I have ordered both the bridge and several plugs from your linked suggestions. Fingers crossed I get it to work :stuck_out_tongue:

So, I ordered all the stuff and I even made sure I updated the firmware. But who can help me with the next steps? I still see the power reading ik dconz, but the reading is not visible in HA.


  • Wich one manufacture name ?
  • Are you using a DDF ?

The device name is _TZ3000_gjnozsaz. Exactly the same as bagira bought. But I am stuck at the point of making modifications to the DDF.
I don’t have any experience at this point and I don’t have a clue what to do :stuck_out_tongue:

So the PR for thoses device is new, and not yet validated

Without DDF, you can’t make tests.

How to use DDF DDF cheat sheet · dresden-elektronik/deconz-rest-plugin Wiki · GitHub
Or can just install the DDF on the “devices” folder.
If you are using HA How to add/edit a DDF on Home assistant using text editor?

So I’ve added the DDF, and it seems like it’s picked up properly. I can control the outlet and read the active power through Phoscon. It’s just that HA only shows me the on/off entity and no power. Any idea’s?

@Smanar If this all works well, I’ve provide feedback on your PR.

If it work on phoscon (at least you can read then in the API using it), it need to work on HA too, both application use the same API.
Can be just a “synchronisation” issue (Happen if the device is updated after it was added in HA)

I changed the status to Gold and then it worked.