New Tuya Smart Plug: NAS-WR01B or _TZ3000_w0qqde0g

Ha nice, this one is not so bad, you have made it from scratch or use an old one ?
We need to put one for plug here DDF-Library - deCONZ Community easier to find for other users …

I think I took the SHP15 one and added it by removing and re-dragging the bindings. I also think there is already a DDF for these plugs waiting for the next build in the repo (not yet included in 2.13.4).

1 Like

Ha yes, I have find it DDF for Neo NAS-WR01B by torandreroland · Pull Request #5577 · dresden-elektronik/deconz-rest-plugin · GitHub

I am unsure what is going on, but when I add more of these plugs using my DDF, deconz starts lagging and eventually becomes unresponsive. I am wondering if there is a bug with DDF in 2.13.3+, since I saw this with the Lumi light sensor and now these plugs as well. Or something is wrong with my setup, although it worked fine for over a year (only the plugs are new)…

I plugged back the SHP15’s (_TZ3000_mraovvmm) and all is well again without any custom DDF.

Can you please either:

  • Stick to one place raising the unresponsiveness
  • Create a seperate forum post on it. Make sure to add logs.

For the unresponsiveness Light sensor not responding in 2.13.3 in "Hybrid mode - #20 by iisworks
I think it can be interesting for manup

Did it update without problem? I’ve bought 3pcs of this plug and also some tuya bridge - its showing firmware update but stuck on Updating to V1.0.10 and progress bar is 0% “Checking for updates”

It takes about 5 minutes per plug but worked fine here for all 10 plugs.

BTW: I ordered 5 more of these compact orange Tuya plugs, and they have a different manufacturer name: _TZ3000_gjnozsaz. In 2.14 they only support On/Off without a DDF.
I also updated them to the latest Tuya 1.0.10 FW (ApplicationVersion 74):

This is the same model I’ve got 2 weeks ago :slight_smile: And cannto update to 1.0.10 via Tuya bridge :frowning: maybe its faulty?

I know that i maybe doing little off topic but maybe could you share photo or model of your tuya bridge?

Have you tried from another device or network maybe?
My Tuya model is LQ-W1 (Zigbee/Wifi, no BT), Usb-c powered, 7x7x1.2cm.

Just borrowed 1pcs to friend with different tuya bridge and it worked…so seems that my bridge may be some kind “broken” (tried different wlans/psu/reset/reconfigure)
The plug itself seems to be one of the best in case price/quality. Works nice as router and after fw upgrade reports usage in seconds instead of pooling!

Can you please provide a link to the bridge you bought?
On Ali I was unable to find a Tuya bridge with the type LQ-W1 or dimensions of 7x7x1.2cm.

I want to buy a bridge also to be able to update my Tuya plugs

It no longer exists, but I would just take the risk and order one for $15. :slight_smile:

Any Tuya powered bridge should be OK - my 1st bridge was probably “broken” I’ve ordered new bridge with LAN connectivity and was able to update 3pcs of this plug without problem.

Would you mind testing on 2.14 with a few plugs? I have been struggling a lot over the last few weeks in combination with DDF (inclusing the built-in “Silver” DDF):

I am really curious to know if others are also having issues!

Well, currently I’m on 2.13.4 (official deconz addon to HA) and added manually DDF (for this neo plugs) to container. I was afraid that it will couse same issue as you described but since yesterday when i’ve joined updated 3 pcs neo power plugs, deconz still works ok. The other power plugs are Blitzwolf BW-SHP13.
In my case to test 2.14 beta i may require some changes in my stable environment :slight_smile:

Mmmm… I was already having issues on 2.13.4 as well. Did you use the “Silver” NEO Plug DDF that is in the deconz repo, or did you create your own? And do they report properly, no delays or issues? Did you also try to “Hot reload” in DDF Edit mode for the NEO plug?

I think the SHP13’s are not using DDF yet (they are polling only). My issue might be related to my 5 existing SHP15 plugs, who somehow seem to be loading/using the same NEO DDF, even though they have a different manufacturer name. I am still trying to find out how this is officially supposed to work. :frowning:

BTW: As described, fallback is relatively easy: restore a working database.

1 Like


I want to share my experience with these plugs.

I bought 3 orange plugs from Aliexpress:

While waiting for them, I found this thread and @iisworks comments that there is a new Firmware for these plugs and you also need a Tuya Hub to make the update. So I did order Tuya hub from here: and I successfully managed to upgrade plugs with new Firmware(1.0.10).

Next, I added these plugs to deCONZ through Phoscon App web interface(Home Assistant deCONZ addon). I could only control On/Off state from Home Assistant, no Power and Consumption Measurement sensors were added. Manufacturer for these plugs is _TZ3000_gjnozsaz.

To make Power and Consumption sensors available and updating in Home Assistant, I did this:

  1. Created new NAS-WR01B_2.json file inside directory /usr/share/hassio/addons/data/core_deconz/.local/share/dresden-elektronik/deCONZ/devices/neo/ (neo directory didn’t exist, so I created it by myself)
  2. To NAS-WR01B_2.json file inserted DDF, mentioned in #62 comment by @Smanar (sorry I can’t add more links because of new user policy)
  3. Inside file replaced:
    • manufacturername to _TZ3000_gjnozsaz
    • status to Gold
    • path to /devices/neo/NAS-WR01B_2.json
  4. Restarted deCONZ Addon
  5. Restarted Home Assistant (somehow Measurement sensors didn’t want to update their state/attributes until I restarted)

Now I have 3 relatively cheap smart plugs that reports power measurement data.

1 Like

There is a bug in 2.14.1 that allows you to use any TS011F plug with the built-in NEO DDF (DDF needs to be in Silver mode during pairing):

But I’m very curious to know: are you experiencing any slowness/delays in deconz with these plugs on the new Tuya FW connected?