Maximum Supported Devices: 500 now (vs 200 previously)?


I have a large system. ~350 devices, almost all Philips Hue bulbs. I have read multiple places that my ConBee II with deCONZ software supports “around” 200 devices. I read in a recent reply elsewhere in this forum by @TheNON75 that “it has been lifted up to 500 recently”.

What version did this occur and was this simply a software update that allowed this or a specific hardware version of the ConBee II stick? If the former, what version did this occur?

I’m running version “2.13.02 / 11/10/2021” and firmware “26660700” (via docker: deconzcommunity/deconz).


This was done in:

1 Like

Thank you! Perfect.

1 Like

Hello, you have a working network with more than 200 devices ?

I am! As of about an hour ago. 245 at the very second. More coming.

Nice, for my curiosity ^^, no stabilities issues ?
No need to restart the network sometime ?
Are you using the “source routing” ?
80% of philips devices ?
Are you making “big zigbee group” ?
Do you have a mesh capture ?

Nice, for my curiosity ^^, no stabilities issues ?: Not yet.
No need to restart the network sometime ?: Not yet.
Are you using the “source routing” ?: Not yet, but plan to.
80% of philips devices ?: More like 99%.
Are you making “big zigbee group” ?: Not sure what this means.
Do you have a mesh capture ?: Not sure what this means.

Are you using “zigbee group”, for exemple a group with a remote to manage a group of light, or use massively third app for automation.

A mesh capture, a picture of your zigbee mesh visible in the GUI for exemple


I am using Home Assistant to manage everything. Screenshot is a mess but there you go!

1 Like

Everything has been super stable. No issues at all so far.

Impressive, I think the source routing helps a lot here.

In the past the 200 device limit was a hard coded number in the firmware. With recent versions it is set to 512, theoretically a network could contain 64K devices, but this wouldn’t work in practice :slight_smile:

There were some tests in the past by various stack vendors with about 400 devices, this can work but highly depends on which devices are used and how they are distributed.

The source routing is crucial here to minimize routing problems in larger networks, note however I’d recommend using it with the latest stable firmware version if you’re running into issues when scaling up the network.

Another side node, if the deCONZ GUI becomes too slow due all those connection links displayed it might be worth to set the Minimum LQI display to a higher value like 200 to hide weak connections, this can be found under "Panels → Source Routing.

1 Like

Thanks for the tips, @manup!

I have about 30 more Hue bulbs and 15 more Phoscon FLS-CT lp controllers and that’ll be where I stop.

For anyone interested: I’m running in a Docker container on Ubuntu on a powerful NUC.

Hi, @manup! Follow-up question here.

I currently have 322 nodes. Things were working wonderfully until everything quit working and I found out that the conbee II was disconnected from the deCONZ software (when VNC’ing in, I was logged out and had to log in again) which happened a few times before the network was big so I think it’s an unrelated issue. Regardless, I restarted my docker container and then all the source routing started building again (this is another issue that I’m not sure has been addressed yet but it does seem to start from scratch on restarts, which is too bad).

ANYWAY, it got me thinking: What are the ideal source routing settings for a network of this size? Devices are only lights (a dozen dresden elektronik strip controllers and several hundred Hue bulbs). Right now my settings are:

  • Maximum hops: 6
  • Minimum LQI: 150
  • Fast neighbor discover (unchecked)
  • Minimum LQI display: 200

Would appreciate any advice!


EDIT: Adding versions/etc. in case that’s helpful:

  • deCONZ v2.13.4
  • Qt: 5.9.5
  • GCC: 7.5.0 (C++ 201402)
  • Commit: 89e0c7
  • Firmware: 0x26660700

Hi wow I’m still impressed this is the I only active network > 300 nodes I know of. There have been tests with > 400 nodes a few years ago but this was in lab conditions.

The ideal source routing settings depend on the specific network but I think for home conditions yours should be fine. In my home network I have similar settings, but in commercial networks I tend to have Minimum LQI set to 200 and above, but this only works with every node being a power amplified repeater like the FLS-PP lp (these can cover up to 150m).

Since you’re having FLS-PP lp in your network you may try to update a few of them to version 201000F5, this version brings a few improvements for source routing and network stability, but I’d recommend to do this selectively for single units (not putting the file in the “otau” directory):

For the source route recreation there have been a few fixes in the deCONZ versions after v2.13.4 so that the routes get stored and reloaded correctly (however I still have a few networks where this occurs, so investigation is ongoing).

Piece of art :stuck_out_tongue:

this thread gives me hopes that my network of 150 devices can handle 5 more Ikea bulbs :slight_smile:

apart from the occasional drop off, sometimes I have issues re-pairing a sensor and I need to restart my raspbery pi… deconz plug in for HA on a pi 4 with 8 GB is at 2.2% CPU + 2 % Memory utilization.

Giving the fact that I use ikea / osram / lidl / aqara / tuya / heiman / sonoff/ enshine conbee 2 + deconz + home assistant is miles away from where Matter with Thread suppose to be…

Piece of art indeed.