Lumi.curtain issue

I have a couple of lumi.curtain devices in my office.

Way back when I first got my curtain, I was having issues with the motor running the wrong way. There was an option in the deconz GUI to change the direction, and that worked.

I’m not sure when, but the issue with the curtain was resolved, and now my curtain was working the “wrong way”. Since I control this thru an event in HomeSeer, I made the event change the direction, everything worked and I sort of forgot about it.

I’ve added a couple more lumi.curtains to my home office and the rest of the house, and I now have this one device that works in the wrong direction.

I’ve been looking in the GUI the last couple of evenings to try and work out which setting I could change, but I can’t seem to get any to work.

I’ve tried removing it from deconz and adding it back in, and that didn’t work - I didn’t really expect it to.

The web says to hold in the button underneath the motor till the light flashes blue to do a factory reset, but that doesn’t seem to have changed things either.

Does anyone know where in the GUI the option is to change the direction of the curtain motor is now? Failing that, does anyone know how to do a full hard, factory reset on the motor?

Is the ability to reverse the direction of the motor something that should still be available with the DDF configurations?

Currently I’m running 2.14.01, with firmware 26400500.

Thanks very much.


I am not sure if this works, but in the Window Cover cluster, you have 0x0017 “mode”:

Here you can perhaps reverse it.

IF that doesn’t work, you can try to remove the device from your window and turn it around yourself.

Thanks. That seems to have fixed it.
For some reason, I had to make the setting about 6 times before it took hold, but I now have my curtains working the same way now.

Thanks very much for the help.


1 Like