Latest DSM update kills my Deconz setup

I can’t choose the right usb port anymore in the Deconz add-on for Home Assistant. Everything is on the latest software. It started doing this after the latest DSM update for my Synology that was available today. I’m running HA on a virtual machine.

You updated from 6.X to 7.X?\

Version: 7.0.1-42218

  1. USB devices (Wi-Fi dongle, Bluetooth dongle, 3G/4G dongle, USB DAC/speaker, and DTV dongle) are no longer supported. If your Synology NAS is currently connected via a wireless dongle, it will be disconnected after the update.

yeah yeah yeah, that has been the case for several dsm releases now, since version 7, that didn’t stop it from working until the previous DSM 7 version

info center says it’s there, it’s updated to the latest firmware, yet ha deconz add on doesn’t see it

Did you forward it to the VM?

Does it show in the HA hardware page?

Thx for your answer. Forward it to VM? Where in Synology or virtual machine manager do i do this?Never done that the previous times and that didn’t stopped it from working.

What’s the HA hardware page? I’m not familiar with that. If you mean add-ons, it’s there, but not wokring because it can’t establisch a connection of course.

Everything is there like it was yesterday evening. Only thing that changed is that damn DSM and I can’t choose the correct port anymore in the HA deconz add-on configuration panel.

I tried everything by now and yet it’s still not showing up.

Sorry i misunderstood something, by hardware you probably mean “apparaten (in Dutch)” page, yeah it’s threre, but it gives an error that it can’t connect

In the VM Manager, you need to attach the stick to the VM, otherwise it wont work:
strong text

This is in DSM 6.2, but i figure it should be the same.

Normally in the HA environment it would show connected devices (supervisor screen). I am not sure where they moved that in the newer version of HA.

What error does it give in the addon?

Either way, issues like these made me move to a seperate VM for just deCONZ with Raspbian on it.

Okay, found it, virtual machine lost it’s connection to correct usb device for some reason upon restart of the Synology machine after updating. Reconnecting it in the VM manager like you showed me in your reaction/screenshot solved it. Thanks!

1 Like

This happens with all devices is my experience. Sometimes synology just ejects it. No clue why, it just happens.

I have a arduino attached and that has the same issue.

Are you on discord by any chance? I am wondering about DSM 7.

yeah I’m on Discord, Stefan#9608