Kobold switch not working


I recently purchased two Kobold dimmer switches. I have installed them the same way as my previous Sunricher dimmers putting 230V AC load on the push button switch input. But nothing happens when I push the switch, I have even tried to put 12V DC on the switch input but nothing happens. I have tried configured the switch both as an advanced switch and basic switch to control groups of lights with no succes. When I use binding dropbox to bind cluser 0x6 to the light, the light flashes rapidly when I push the button.

What could be wrong? Both swicthes behave this way. After a while the switches become gray in phoscon

Phoscon says software version 0.9.28. Deconz says: 0.0 build 4. I have tried to update from Index of /otau/ (dresden-elektronik.de), but otua doesn’t seem to pick that file.


I finally solved it by upgrading firmware.

I manage to query an upgrade after I put the firmware file in C:\Users\Username\otau (Windows) I then clicked Query next image after several resets of the dimmer switch.

I bought the switch from Amazon and it come with a very early and buggy version 0.0 build 4.