IKEA Styrbar - how to setup/configure?

I have successfully paired the IKEA Styrbar remote control in Phoscon and it shows up in Deconz as well as HA. However, I have some problems.

  1. I am unable to capture any events from the controller in HA, clicking the buttons does not fire any visible events in HA
  2. Clicking lights+/- on the remote control turns on/off two Silvercrest extension plugs even through I have not configured any actions etc anywhere for the Styrbar remote.

How can I setup the Styrbar remote so I can capture the events and use it in HA, and have it not turn stuff on/off that I have not configured?

Thanks!

Do you see events for the Styrbar at Phoscon App > Menu > Help > API information > Events?

You should see the same events in HA as deconz_event

I have the same issue here, buttonevents are never send through the webhook, buttonevents reported are still null. I have waited here now for two hours, regularly pressing a button, without any updates. Only the report is send over the webhook, without much useful info.
Maybe it is a different version we have?

For completeness, the RESP API reply after a few more hours, a restart of deCONZ and pressing the buttons on the device. It is unresponsive, except for reports:

{
“config”: {
“alert”: “none”,
“battery”: 100,
“group”: “31”,
“on”: true,
“reachable”: true
},
“ep”: 1,
“etag”: “7be9fe52e90cdc0e4cc4b64f5ae7da82”,
“lastannounced”: “2021-11-02T11:17:53Z”,
“lastseen”: “2021-11-02T11:17Z”,
“manufacturername”: “IKEA of Sweden”,
“mode”: 1,
“modelid”: “Remote Control N2”,
“name”: "Remote Control N2 ",
“state”: {
“buttonevent”: null,
“lastupdated”: “none”
},
“swversion”: “1.0.024”,
“type”: “ZHASwitch”,
“uniqueid”: “cc:86:ec:ff:fe:63:89:c9-01-1000”
}

I’ve just unpacked mine, seems to be working fine.

"116": {
    "config": {
      "alert": "none",
      "battery": 20,
      "group": "10",
      "on": true,
      "reachable": true
    },
    "ep": 1,
    "etag": "82d4498c063e430d426c4342595c527d",
    "lastannounced": null,
    "lastseen": "2021-11-02T14:29Z",
    "manufacturername": "IKEA of Sweden",
    "mode": 1,
    "modelid": "Remote Control N2",
    "name": "Remote Control N2 ",
    "state": {
      "buttonevent": 2002,
      "lastupdated": "2021-11-02T14:29:29.058"
    },
    "swversion": "1.0.024",
    "type": "ZHASwitch",
    "uniqueid": "84:2e:14:ff:fe:42:33:43-01-1000"
  }

I gave up and deleted the device in deCONZ and readded it. It started from then on. I guess something went wrong the first time I added it. But don’t know what I did different this time… this all was on 2.13.1

@ich No events are visible in Phoscon when pressing buttons (but Silvercrest power strips are turning on/off)

@w.vuyk I tried deleting and re-adding the remote several times. The information looks the same as in your screenshot from deCONZ. I also get the report in REST API same as yours, but no events.

Perhaps Phoscon version or Conbee II firmware issue? I’m on Phoscon version 2.13.00 and firmware version 26660700. What versions are you running @w.vuyk @Swoop

Updated to Conbee II firmware 26720700 but no change in behaviour.

We know that there is an issue with the STYRBAR and work at it.
Pleace be patient.

2 Likes

I’m in doubt there’s a issue… It seems that the strybar is paired to the lidl ledstrip. Same can happen with the round ikea remote.

The fact that it works for others kind of confirms my thoughts.

This is how it looks in deCONZ for me. So it looks as if it’s connected directly to the Conbee II stick… however no events visible in Phoscon/HA, and still turns on/off the Silvercrest outlet power strips.

image

Hi, any news on the works on Strybar? Unfortunately it still doesn’t work for me…

Are there any news? :slight_smile: