Ikea CWS 600lm bulb, no 'Color temperature' in Phoscon

deconz 2.26.3
Bulb firmware 2.3.093
Added for many years, pre DDF.
Just tried deleting the light and re-adding. Did not help.
Nothing happens when Hitting the ‘Color temperature’ button, making it hard to tune in a white color.

The ‘ct’ mode seems to be missing in REST:

  "capabilities": {
    "alerts": [
    "color": {
      "effects": [
      "modes": [
      "xy": {
        "blue": [
        "green": [
        "red": [
    "transition_block": true
  "colorcapabilities": 15,
  "config": {
    "bri": {
      "execute_if_off": true,
      "on_level": "previous",
      "onoff_transitiontime": 5,
      "startup": "previous"
    "color": {
      "execute_if_off": false
    "groups": [
    "on": {
      "startup": "previous"
  "etag": "743fb71ccbbe3b9e697e88876fa7a5b9",
  "hascolor": true,
  "lastannounced": "2024-05-04T23:32:33Z",
  "lastseen": "2024-05-05T11:15Z",
  "manufacturername": "IKEA of Sweden",
  "modelid": "TRADFRI bulb E27 CWS opal 600lm",
  "name": "Trumpet single 11",
  "productid": "LED1624G9E27EU",
  "state": {
    "alert": "none",
    "bri": 149,
    "colormode": "xy",
    "effect": "none",
    "hue": 0,
    "on": true,
    "reachable": true,
    "sat": 0,
    "xy": [
  "swversion": "2.3.093",
  "type": "Color light",
  "uniqueid": "00:0b:57:ff:fe:a7:ea:12-01"

I have tried adding ‘ct’ capability modes using the DDF editor, but no success.
/ct/max & min are added, but max value is 0 although default value says otherwise.
Any hints?

Are you sure this device support it ?
From this post IKEA TRÅDFRI TRÅDFRI bulb E27 CWS opal 600lm RGBW Bulb Color Temperature not working · Issue #4140 · dresden-elektronik/deconz-rest-plugin · GitHub it seem not.
And the official DDF don’t use them.

Can try a DDF with color + CT and just change the model id

Not sure after reading up on that Github link.
I only have 3 bulbs and they are 1. gen everything, so I might just replace them.
Fairly certain they used to work a couple of years ago, but that’s progress.
Also updated the firmware on them, and that might have done something as well.

But, Phoscon should perhaps not show the ‘Color temperature’ button at all when it is not supported?

@de_employees Can you reply on this?

I can check if the color temperature button is displayed mistakenly.
But if the color temperature is not controlable by app I probably can’t do anything. Then it is a DDF thing or the light does not support it.

You could test to pair the light again in legacy mode. Just disable the boxes in deCONZ in the Control panel:


Will try, but not at the site until next week.