Hue Dimmer Switch Disconnected


I’ve been running Home Assistant with Deconz for a year or two on Proxmox. The other day, my Hue Dimmer (1st gen) disconnected and hasn’t worked since. I’ve tried rebooting the whole system, updating the Deconz plugin, but it remains disconnected. I also tried a reset of the device by holding all four buttons. The battery is fine.

Is there any way I can reconnect this without messing the configuration up in Home Assistant? I’d rather not have to add it as a new device and redo my automations if possible.


You reset it with a reset button on the back.

No clue why it stopped responding. Perhaps you have interference issues?

Could be interference, I guess. In the end, I decided to remove and add the device again which stopped the red LED from lighting on button presses. Then maybe 20 minutes later it started working with my automations again.

1 Like

The original Philips Hue 4 button switches had terrible firmware. Make sure that they are upgraded. I am not sure if there are files available. Worst case you have to do a temporary pairing on a Philips Hue hub.
My switches were upgraded to and since then they worked much more stable. They can rarely go bad but not daily as the original firmware.

There is a secret way to make it reconnect without resetting or repairing. Press all 4 buttons for a around 5 seconds. The LED will flash red and green a few times. That will normally force it to find a route back to the coordinator. You maybe have to try a few times. Make sure to do this where the switch resides normally.

1 Like