How to delete an unreachable Phoscon Gateway

TLDR; When I use Phoscon app, I saw one gray out (screenshot below) which I can’t find a way to completely remove it.

Background: From a few weeks ago, I suddenly can not control my smart switches with RaspberryPi 4 + Homebridge + Hue plugin + deCONZ, which has been working fine for over a year. I thought my RaspBee is broken as it happened once before, so bought a new RaspBee2 from Amazon and replaced the old one. Then I can set up the network via Phoscon again (first one in the screenshot above) and can successfully control lights via Phoscon, but I still couldn’t control switches via Homebridge & Hue plugin & deCONZ (Homebridge can connect to Phoscon via websocket but not recognise accessories).

Other things I tried but also failed:

  • Reboot RaspberryPi, Homebridge, update versions & plugins
  • Use Homebridge deCONZ plugin instead of Hue plugin
  • apt uninstall deconz and sudo rm -rf ~/.local/share/dresden-elektronik/ and reinstalled deconz again.
  • Clear cache of browser

So my guess right now is that Homebridge connects to the wrong Phoscon gateway in the screenshot, hence the question, how to remove it?

Hello, They have same IP adress, so your third app can use the one it prefer.
It’s not an API key problem ?

I don’t think so. I can login to the 1st one and enable authentication so Homebridge plugin can find it. However, I couldn’t find any other way to validate all these before trying to remove the 2nd one completely. Eliminating possibilities one by one. I don’t want to format the whole RaspberryPi because deCONZ or Phoscon is not working.

And you have same result when using ? Phoscon App

What is the result of

Using Phoscon app (1st gateway from screenshot) can control switches.

Discover result:


You have 2 gateway displayed ? even using the phoscon public adress ?
And on the discovery you have only one, the one called "“Phoscon”. So Third app will use this ip on port 80.

You have tried with another browser ? from your smartphone for exemple ?

And if you close your deconz session ? both gateway disapear ?

The grayed out gateway should be the legacy gateway remains. After deleting the browser cache and the app data of the browser it should disappear.

This is it, it disappeared! I only tried clearing cookie, but didn’t try app data (which is in advanced menu). Thank you.