HomeAssistant: Automations involving DeCONZ get stuck ever since Core 2023.8 (or 2023.7.3)

As reported here extensively, there has been a problem with automations getting stuck since updating to core 2023.8. The problem is a total showstopper (requiring rebooting), that is why I (and others) had to roll back to an older version of the HA core. My stuck automations all rely on DeCONZ devices. That’s why I have been urged to get in touch with the kind people working on the DeCONZ integration. Hope this is a good place to reach them.

It seems like the problem was also addressed on Github (here). However, the issue was closed without an obvious solution. The discussion diverged to Z-Wave JS which apparently caused similar problems. However, according to this issue the problem has been solved for Z-Wave JS. Perhaps this could serve as guide to also solve the problem with the DeCONZ integration.

Allen Porter comments here: “For zha maintainers, some context in #98073 (comment) and PR #98501 – service calls used to have a default timeout and now we’d like to fix the root cause of the issue and ensure that integration services calls don’t hang forever or resolve the underlying root cause.

The problem for me is confined to automations relying on DeCONZ, although manually manipulating the DeCONZ devices through Lovelace is no problem at all. Unlike first thought in the original thread, this has nothing to do with automations restarting themselves. It happens with all kinds of automations.

Please do help if you can! It has been almost three months of hoping without really any light at the end of the tunnel, yet.

@Robban can you comment?

1 Like

Posted here as well. DeCONZ: Automations get stuck ever since Core 2023.8 (or 2023.7.3) - #2 by Robban - Third party integrations - Home Assistant Community

1 Like

I am so glad you responded @Mimiix and @Robban ! Thank you so much! Your assistance is much appreciated.

Actually, I tried to submit the issue to Github on Sep 10. For reasons unknown to me, only I can see it when I am logged in. Nobody else can. And there is no option to “release” the issue or anything like that which I could find on the Github page (link - probably dead for everyone else). Here is the original content of that issue:

Potential deCONZ timeout issue causing HomeAssistant integration to fail ever since HA version 2023.8 #7219

## Describe the bug

Automations relying on deCONZ are getting irreversibly stuck (i.e. showstopper) in versions of HA core 2023.8.0 through 2023.9.1 after upgrading from 2023.7.3.

A similar problem is being dealt with in issue https://github.com/home-assistant/core/issues/98073, however, they are focusing on ZHA exclusively. The same problem affects deCONZ as well.

An issue has been filed on the HA git. https://github.com/home-assistant/core/issues/100048
However, I assume the deCONZ maintainers might need to be involved in this. Therefore, I am adding this here. My apologies if I am mistaken.

User Petro on the HA forum describes the problem like this:

A timeout was removed from automations to allow for services to return data.
This timeout will never be added again.
This timeout allowed automations to continue when a service call lagged beyond 10 seconds,
which should never happen.


## Environment
  The deCONZ and firmware versions are found in the Phoscon App: Menu -> Settings -> Gateway,
  as well as in the deCONZ GUI: Menu > Help > About deCONZ.

 - Host system: Raspberry Pi
 - Running method: Home Assistent deCONZ Add-on
 - Firmware version: 26720700
 - deCONZ version: 2.22.02 / 9/19/2022
 - Device: ConBee II
 - Do you use an USB extension cable: yes
 - Is there any other USB or serial devices connected to the host system? no

The aforementioned link to the HomeAssistant Github is just as “dead” as the quoted one.

Anyway, I assume the summary I posted above when I started this thread might be a little more up to date and, hopefully, also a little more helpful in resolving this problem than my original (failed) attempt at filing that Github issue.

Will this by any chance help you?

Allow me to finish off by mentioned how much I appreciate and enjoy DeCONZ. I now have 107 devices providing 245 entities connected which until July/August everything had been working like a charm! Kudos for than wonderful hard- and software.


No clue what happened with that issue. I never got a email nor can I find it. Nevertheless, this would be closed as it is not a bug in deconz but in the integration.

@robban could you please share the correct GitHub ?

Try reporting it here GitHub - home-assistant/core: 🏡 Open source home automation that puts local control and privacy first.

Managing and tracking issues through the forums never work out well.

Thank you once more for your replies!

So, I tried to post the first message of this thread as an issue on GitHub - home-assistant/core. The same thing is happening again. I can only see the issue when I’m logged in. Else, one receives a 404. (link - again probably dead) Even the user account receives a 404.

This is part of what I see:

Automations involving DeCONZ get stuck ever since Core 2023.8 (or 2023.7) #102172


[sailorhub77] opened this issue Oct 17, 2023 · 0 comments

I have absolutely no clue why this isn’t working. I click “New issue”, fill in the form and submit. (I assume this is how it’s done.) Once submitted all the options I see are “edit”, “comment” and “close”.

Would perhaps somebody else be able to file that issue? Seems like my hands are tied.

I think you should look into getting your GitHub account fixed, if additional actions are needed from you it is better to get it sorted out up front.