Gateway work on command line, but not on deamon

on a debian buster, when i start deConz with a command line (/usr/bin/deCONZ -platform minimal --http-port=8099 -–http-listen=, my gateway is find, but when i start the service (systemctl start deconz)
the gateway is not find.
any idea ?
thank for your help

When you make systemctl start deconz
Just after make ps ax | grep deCONZ and compare with /usr/bin/deCONZ -platform minimal --http-port=8099 -–http-listen=
I think you will se the fautly/missing parameter

or systemctl status deconz

By default this is port 80, not 8099, may be it’s the issue here.

i found my problem, a have a User=1000 in /lib/systemd/system/deconz.service file
i changed it, and all work, i have my gateway whith the good informations

thank you to all

I have the same problem.
Which value do you choose?


What’s the r id of the user used to install DeConz ?

I’ve installed it under root.

Sometimes, I’m not clear in my brain. Sure I must use the user-id from root.
Now it works :slight_smile: