Device loose connection or dissapear

I have a problem with my RaspBee II and not sure if I should post it at github as open Issue. I use Phoscon 2.19.03 with a RaspBee II with FW 19.9.202 on a Pi 4 8GB with latest Bullseye 64bit without GUI.
Problem: From time to time some of my SONOFF sensors or HUE components dissapear.
Case 1: They are still shown in the Phoscon App but not updated
Case 2: Sometimes they completly dissapear in the App
Case 3: Sometimes they are displayed in light grey and they come back sometims
To get them back working I have to search again for new sensors / switches / lights and sometimes I have to reset them to get them back to the system.
First I just thought this problems is just a problem of my SONOFF sensors. But now I moved all my HUE lights / switches from my HUE bridge to deConz RaspBee II (so that the HUE Bridge is not needed anymore) ans also start having problems. I got the feeling that the system is working slower than the HUE bridge.
I have a few rules on OpenHab which uses events to trigger my lights. After a long press on a HUE switch for example. Now it takes a few seconds until the light is switched before it was instantaneous.
Also one rule is switching light on for just 2 seconds and turn it off again. Now it keeps on and maybe 1 of 10 tries switches the light back off after 2 sec.

Part of my log:

02:57:54:195 Delay APS request id: 24 delayed, 20 ms till send
02:57:54:244 Delay APS request id: 24 delayed, 20 ms till send
02:57:54:294 Delay APS request id: 24 delayed, 20 ms till send
02:57:54:344 Delay APS request id: 24 delayed, 20 ms till send
02:57:54:394 Delay APS request id: 24 delayed, 20 ms till send
02:57:54:444 Delay APS request id: 24 delayed, 20 ms till send
02:57:54:495 Delay APS request id: 24 delayed, 20 ms till send
02:57:54:591 APS-DATA.confirm id: 24, status: 0x00 SUCCESS
02:57:54:591 APS-DATA.confirm request id: 24 → confirmed, timeout 218716

03:03:09:595 APS-DATA.request id: 224, addrmode: 0x03, addr: 0x00178801098ee185, profile: 0x0104, cluster: 0x0006, ep: 0x01 → 0x0B queue: 0 len: 5 tx.options 0x00
03:03:09:595 asdu (length: 5): 101f000000
03:03:11:630 APS-DATA.request id: 229, addrmode: 0x03, addr: 0x001788010402a6fe, profile: 0x0000, cluster: 0x0031, ep: 0x00 → 0x00 queue: 1 len: 2 tx.options 0x00
03:03:11:630 asdu (length: 2): 640a
03:03:13:794 GW firmware version: 0x26780700
03:03:18:794 Daylight now: nadir, status: 100, daylight: 0, dark: 1
03:03:23:795 GW firmware version: 0x26780700
03:03:26:794 sql exec SELECT conf FROM zbconf ORDER BY rowid desc limit 1
03:03:26:794 Idle timer triggered
03:03:26:794 Force read attributes for ZHASwitch SensorNode Dimmschalter Wohnzimmer
03:03:26:794 Force read attributes for ZHASwitch SensorNode Dimmschalter Küche
03:03:26:794 Force read attributes for ZHASwitch SensorNode Dimmschalter Keller
03:03:28:794 Daylight now: nadir, status: 100, daylight: 0, dark: 1
03:03:33:794 GW firmware version: 0x26780700
03:03:36:894 [Master] kill cmd 0x12 (TIMEOUT)
03:03:36:894 APS-DATA.request id: 224, status: 0x03 giveup
03:03:36:894 APS-DATA.request id: 224, set state: 0x05
03:03:36:894 emit artificial APSDE-DATA.confirm id: 224
03:03:36:894 Poll APS confirm 224 status: 0xAE
03:03:36:894 drop item attr/modelid
03:03:36:894 drop item attr/swversion
03:03:36:894 drop item state/bri
03:03:36:894 drop item state/colormode
03:03:36:894 0x00178801098ee185 error APSDE-DATA.confirm: 0xAE on task
03:03:36:894 Erase task req-id: 224, type: 19 zcl seqno: 31 send time 28, profileId: 0x0104, clusterId: 0x0006
03:03:36:910 aps request id: 224 failed, erase from queue

Hello, have you tried with an older deconz version ? 2.18.X ?

Yes problem keeps the same.

Can you share a full debuglogs with log levels as described in #deconz

Part I
Part II

You have interference issues

03:00:00:922 0x00178801098ee185 error APSDE-DATA.confirm: 0xE1 on task
03:00:00:922 Erase task req-id: 49, type: 19 zcl seqno: 164 send time 0, profileId: 0x0104, clusterId: 0x0006
03:00:00:922 APS-DATA.confirm id: 49, status: 0xE1

Are you using an extension cable?

Extension cable not possible with a RaspBee II. Turned Wifi and BT off. Nothing connected to USB. Tried also to move the Pi in other rooms. But shouldnt the devices come back automatically? My temperature Sensors from Sonoff keep diconnected until I search for them again.

What exactly in this part of the log file shows that there are interference issues?

By the way Happy New Year and thx for helping

As long as you see 0xE1 there’s interference.

Are you using the a SSD or other usb 3.0 devices ?

Happy new year to you too :slight_smile:

There is nothing connected to my Pi. I also turned off BT and Wifi. Also tried to change Zigbee channel. But the problem keeps the same. All seems to be slower since I paired my HUE components to the RaspBee. A long press on my hue dimmer switch normaly activcates my shelly instantly. Now it feels like that the switch must be woke up to give the command to the shelly. Also commands to the lights are not instant anymore. I have a rule switching a light on or off for 1 second and than back to state before. Now I have to increase this time to 2 secondes otherwise the second command to previous state is not executed.

Is the raspberry in a metal case ?

No. just in a simple printed case.

Tried to install now on a new sd card with gui. But I am not able to switch the Port of Deconz. Headless it is no problem but with gui changes are ignored

tried via:
sudo nano /lib/systemd/system/deconz.service-gui
sudo systemctl edit deconz

After reboot the changes were gone.
Changed port of openhab to easy solve this problem but the behavior is the same.

It has nothing to do with network settings or ports.

It has to do with wirelees signals. Please Google for zigbee interference .

I know that the change of the port got nothing to do with my problems. Just want to change them back so that it meets my old configuration with the headless deconz installation.
I will search at Google in the evening. Hope to find something.

1 Like

This might give you a head start.

Additionally: ZigBee and Wi-Fi Coexistence | MetaGeek might help you.

To change port, can use the command line with adding --http-port=8080 --ws-port=20877
But if I m right, you need to edit the file /usr/systemd/system/deconz-gui.service or can use a systemd overwrite

It’s old but Use deCONZ and Phoscon On Non-Standard Web Ports? · Issue #26 · dresden-elektronik/phoscon-app-beta · GitHub

@Mimiix I exchanged the zigbee channels of my deconz and hue gateway. At the moment it seems to be better. I will make a new log file and give an update. Many thanks so far.

1 Like

@Smanar Tried it this way. But i did not work for me. The file/folder which should be changed is not on my pi. Maybe something changed in the meanwhile. Also tried to search for the files without success.

Still looks good. But now I get no message that the devices go offline. Until now I had a rule which was triggered in case that the status changed from offline to online. Now I get no signal that says device is offline.

I don’t think its from your last test, devices are marked unreachable in the API or phoscon too ?

No I also don´t think that is caused by the last test. I think it is caused because now I got a better connection. But in case that I turn off the light by switch I should also get a signal that the device is offline. Before I changed the channel I recived such a signal at OpenHab and used the signal of the device is online to change color temperature of the light depending of the day time.