Deconz won't start after updating from 2.12.06 to 2.13.04

Hi!
I’ve got a little problem with updating deconz to 2.13.04

update seems to work but deconz not running after the update

Steps to reproduce:

  1. wget http://deconz.dresden-elektronik.de/raspbian/stable/deconz-latest.deb
  2. sudo dpkg -i deconz-latest.deb
  3. sudo systemctl restart deconz

no errors until here but

sudo systemctl status deconz

shows this:

deconz.service - deCONZ: ZigBee gateway -- REST API Loaded: loaded (/lib/systemd/system/deconz.service; enabled; vendor preset: enabled) Active: activating (auto-restart) (Result: exit-code) since Wed 2022-01-12 20:11:23 CET; 27s ago Process: 1212 ExecStart=/usr/bin/deCONZ -platform minimal --http-port=80 (code=exited, status=127) Main PID: 1212 (code=exited, status=127) CPU: 1.182s

Downgrade to 2.12.06 and reboot fixes the issue

Environment:

  • Host system: Raspberry Pi
  • Running method: Raspbian
  • Firmware version: 26400500
  • deCONZ version: 2.13.04
  • Device: RaspBee

thanks for help!

Did you install the new dependencies?

yes I did

EDIT: oh ok didn’t know I have to switch to buster repositories. I’ll try this and post an update

EDIT 2: ok now it is working. Thanks!

I have same issue, i did sudo apt-get install -f but do it seems i need to do something else ?

Can you try to install libqt5qml5?

And see afterwards?

@Mimiix thx but apt-get install does that already but i did try again :

pi@phoscon:~ $ sudo apt-get install -y libqt5qml5
Reading package lists... Done
Building dependency tree
Reading state information... Done
libqt5qml5 is already the newest version (5.7.1-2+rpi1).
libqt5qml5 set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 255 not upgraded.

did you switch the repositories to buster? Here you see what you have to do:

Thx, i just tried but nope :frowning:

Jan 14 13:02:57 phoscon systemd[1]: Started deCONZ: ZigBee gateway -- GUI/REST API.
Jan 14 13:02:58 phoscon deCONZ[3115]: libEGL warning: DRI2: failed to authenticate
Jan 14 13:03:01 phoscon systemd[1]: deconz-gui.service: Main process exited, code=exited, status=127/n/a
Jan 14 13:03:04 phoscon systemd[1]: deconz-gui.service: Unit entered failed state.
Jan 14 13:03:04 phoscon systemd[1]: deconz-gui.service: Failed with result 'exit-code'.

UPDATE: I take it back, i thought i did the buster upgrade but didn’t…doing it now. I’ll let you know if this works.

Upgrading to Buster solved the problem, thx