Deconz service will not start any more

Hello, I was wondering if someone could help me with a problem.

I have a RaspBee I adapter on a raspberry pi 3. Everything used to work perfectly (deCONZ service, PHOSCON) and I could control my devices via a phone app. However after (I guess) various system updates the deCONZ service does not start any more.

● deconz.service - deCONZ: ZigBee gateway -- REST API
   Loaded: loaded (/lib/systemd/system/deconz.service; enabled; vendor preset: enabled)
   Active: activating (auto-restart) (Result: exit-code) since Tue 2023-05-30 17:47:39 CEST; 22s ago
  Process: 11848 ExecStart=/usr/bin/deCONZ -platform minimal --http-port=80 (code=exited, status=127)
 Main PID: 11848 (code=exited, status=127)

when I try to start it manually via

/usr/bin/deCONZ -platform minimal --http-port=80

I get the following error:

libpng warning: iCCP: known incorrect sRGB profile
/usr/bin/deCONZ: symbol lookup error: /usr/share/deCONZ/plugins/ undefined symbol: DBG_Printf


PRETTY_NAME=“Raspbian GNU/Linux 10 (buster)”
NAME=“Raspbian GNU/Linux”
VERSION=“10 (buster)”

  • device RaspBee I

deconz 2.22.00-raspbian-buster-beta armhf
deconz_cli_plugin from source 2.04.35

I tried starting the service as
/usr/bin/deCONZ --dev=/dev/ttyACM0 -platform minimal --http-port=80

as described here

but no luck. Same error.

Any ideas?

Hello , have you tried a
sudo apt install deconz

If I remember this message is caused by this plugin GitHub - ma-ca/deconz-cli-plugin: The deconz-cli-plugin can be used as command line interface (cli) to send and receive raw ZigBee commands with deCONZ software.

You can try to remove it from the deconz plugin folder, time for a compatible version, but from my memory deconz just skip a plugin if it have problem.

You are sure not having the GUI version running in same time ?

Hi there and thanks for the reply.

I tried the sudo apt install deconz and it says

deconz is already the newest version (2.22.00-raspbian-buster-beta).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

as for the GUI version I am pretty sure I dont have it running (how can I verify this?). I can only see the following services running:

deconz deconz-update deconz-wifi

As for the deconz-cli-plugin don’t I need this?
I am running on a headless RPI and usually connect via android app to control various appliances via the raspbee adapter.

Did you install deconz-cli before ? If yes have you updated deconz-dev and recompiled deconz-cli eventually ? GitHub - ma-ca/deconz-cli-plugin: The deconz-cli-plugin can be used as command line interface (cli) to send and receive raw ZigBee commands with deCONZ software.

It’s just a plugin, and I think realy few users use it.
I have checked, It’s not in deconz by defaut (at least on my setup ^^), so yes I think too you have it because you have compiled/installed it yourself ?
And yes you can remove it, it will not break the working mode.

yes I compiled it myself (I installed it ages ago so I dont remember the exact process).
ok I ll try to remove it and see what happens

I am sure I installed it for some reason though…

This plugin is used for debugging, not sure you still need it, but you can recompile it too with a recent “deconz-dev package’”

ok, so I tried to find a latest version of deconz-dev package but I couldnt (I think the file was moved somewhere else) so I just removed the plugin library
from the plugins folder /usr/share/deCONZ/plugins (since as you mentioned is not useful)
and now the service works again as before!

Many thanks for the assistance.