deCONZ REST-Api reports MAC Adress 0000000000000000

Since moving on the official deCONZ Desktop image for RaPi, I have a problem to connect the Homebridge/Hue Plugin and Homebridge/Deconz Plugin to REST API. I get an error “[deCONZ] warning: 0000000000000000: not a RaspBee/ConBee Mac address”

When using Hue Plugin by ebauuw, I get the message that the Conbee seems not to be correcty initialized.
Is this a known bug? I never had this before. Pressing the App-Link button doesn’t change it, also several reboots didn’t help.
As I had a Gateway on the same hardware before, this is still shown and greyed out. Is this the reason?

I think if you use phoscon on the gateway page you have “not connected” instead of the firmware version displayed ? (Or no phoscon at all)

If I have understand it have worked before ? No firmware update, no hardware modification, just OS move ?

I can see the Gateway and it also shows the firmware of the Gateway - so it‘s connected. But the bridgeid remains to be all zeros.
With this Homebridge Hue has problems.

Just by curiosity, you don’t have the GUI ? To compare your setting with thoses one Network lost and configuration restore does not help · dresden-elektronik/deconz-rest-plugin Wiki · GitHub

“bridgeid” in the API is updated by API code after the connexion, strange it’s not done if all your config is fine and all is running.

Perhaps something visible in deconz log (if you have the GUI, in help/debug view with flag “info” “info_l2” “error” and 'error_l2")

I use the DeCONZ Raspberry Pi image, which includes the GUI and also the headless services that run. I didn’t change anything and relied completely on the correctness of settings.
The issue also only is visible with the Homebridge Hue plugin and Homebridge DeCONZ plugin. But these ones are of course the most important ones.
When querying the REST API I can also see that bridgeid is report just with zeros.

Perhaps ?

I also still see the following recurring warning in the log on the RPi4 with HB and the Conbee II connected to the USB cable:

[deCONZ] warning: 00000000000000000000: not a RaspBee/ConBee mac address

Here I can see that Conbee has a null bridge ID.

pi@homebridge:/var/lib/homebridge $ ph discover

“”: {
“apiversion”: “1.16.0”,
bridgeid": "0000000000000000”,
“datastoreversion”: “93”,
“devicename”: “ConBee II”,
“factorynew”: false,
“mac”: “d8:3a:dd:03:d4:68”,
“modelid”: “deCONZ”,
“name”: “Phoscon-GW”,
“replacesbridgeid”: null,
“starterkitid”: “”,
“swversion”: “2.21.1”

I have tried the procedure in the link above, but without success. Even there I can see that the GUI deGONZ is not null for the MAC Address field, however, the log still shows the problem and the above error. I only see null entries there unless I quit the deconz running beforehand:
sudo systemctl stop deconz,
then the fields are null.
Is there any other procedure for this?

You mean the value is good on the GUI ? Can you show a capture of the complete tab (even taked with your phone)

Would be interesting to see what the deCONZ GUI → Menu → Edit → Networks Settings look like.
It should look like the following with a valid MAC address:


yes, it looks like this, but still the mentioned message in the log is about zero bridgeid…

[deCONZ] warning: 0000000000000000: not a RaspBee/ConBee mac address - retrying in 60s

APS Use Ext pan ID is bad too, You can compare with this capture Network lost and configuration restore does not help · dresden-elektronik/deconz-rest-plugin Wiki · GitHub

Unfortunately, nothing that would lead to fixing the problem. :frowning_face:
Fix: I take it back… it worked! :open_mouth: