deCONZ - conbee 3 - sonoff snzb-02 not pairing?/working


i got a new conbee 3 and 9 sonoff snzb-02 recently. Except the sonoff’s everything is on latest firmware/software and confirmed working with an osram smart plug. I am running it headless on a RPI4. With an USB extension of course ;).

However i cant get the snzb-02 to pair. I tried at least 5 out of 9 with no success.
I also installed deconz on a windows machine with gui to check whats happening. There the sensors can somehow be seen to appear in the gui but with no content / no cluster menu button. On both machines the pairing process in the webapp failes/times out and no sensor is added. Ive also tried everything i could come up with on the internet like pulling battery, shortening power pins, resetting devices, checked the batterie, restarts, reboots etc…
As i bought everything new i have to make a decision on what to return in time.

So i made a log with the proposed settings which can be viewed here:

Hope someone can enlighten me…


Have you tried removing the battery bevore pairing again? See SONOFF SNZB-02/TH01 - no values reported - #5 by jan666

Yes already tried without success but gave it a second try though. But still same result.
I updated my post with additional info and screenshots.

thanks anyway

Strange. I just paired a factory new Sonoff SNZB-02 with my deCONZ 2.24.2 and Conbee III w/o problems

But the issue is for more than this device. You have 3 unreconized devices on your network. It’s because the device was included on a host, and you are on another for the capture ?

I am not sure if i understand your question as i am new to this. But yes i have made separate installation on a windows machine with desktop as my rpi4 is headless. Only for the purpose of deconz gui/troubleshooting.

edit: log is from rpi4 where i tested 5 sensors and screenshots from the windows machine where i only tested two sensors.

You probably haven’t “migrated” the device setting from a host to the second one, it can explain this result.
But about the pairing issue, perhaps something similar here Cannot join ZigBee network from deCONZ GUI · Issue #7377 · dresden-elektronik/deconz-rest-plugin · GitHub

No i didnt migrate anything those are independent installations. As i mentioned the desired Host is the RPI4 which is headless. I am not sure how the mentioned issue could help me as i am having no gui anyway.

You can btw use the deCONZ GUI with on a headless rpi installation via ssh XForwarding. I use this all the time. You just need a X on your Desktop machine and use ssh -Y …

The problem is device data are stored on the host, so if you use the conbee on another host, you need too migrate your config, else reconised devices on a host will be not reconized on the second one.

On the linked issue, the user have same issue than you, device not reconized (with or without GUI)

Hi Smanar maybe i do not get you right. My only problem is to get the sensors working on the raspberry pi 4 which should be working but unfortunately is not.

Update on my Problem:

With the Conbee III i still cant get the Sonoff snzb-02 to work though they show up in deconz somehow.

So I ordered a Conbee II and tada everything is working rigth away.

As i got my Osram smart plug to work with the conbee III i have no idea what is wrong with that particular stick.

Hi. I am having the exact same issue.

  • DietPI (64bit), installed on a new SD card on Raspberry Pi 3 Model B Plus Rev 1.3
  • 3 brand new SNZB-02 sensors (never used, never paired)
  • New ConBee III, updated to latest firmware.
  • I am using Docker containers

Steps I did so far

  1. The container is booting up. -e DECONZ_BAUDRATE=115200 is set.
  2. The Coordinator is recognized.
  3. Firmware update to 0x264E0900 was done.
  4. SNZB-02 sensors are NOT fully recognized, neither via zigbee2mqtt nor deconzcommunity/deconz:stable.
  5. I also validated this on a Macbook with the native App.
  6. I tried to pair multiple times

In all cases, the initial handshake works but subsequent interviews failed.

Deconz 2.24.2 debug log per my discussion on discord: Ubuntu Pastebin

Deconz GUI on MacOS:

I can also confirm that with my old ConBee II and Zigbee2MQTT, the sensors connected on the first attempt w/o any issue.

So to me, it smells like a bug or incompatibility that can potentially be resolved with a software/firmware update.

Link to Discord thread: Discord

Update 2023-12-24
Today, I again tried to pair the SNZB-02 in my zigbee2mqtt container.
Here are the related logs:

Zigbee2MQTT:info  2023-12-24 07:41:28: Device '0x00124b002a5d2e2a' joined
Zigbee2MQTT:info  2023-12-24 07:41:28: MQTT publish: topic 'zigbee2mqtt/bridge/event', payload '{"data":{"friendly_name":"0x00124b002a5d2e2a","ieee_address":"0x00124b002a5d2e2a"},"type":"device_joined"}'
Zigbee2MQTT:info  2023-12-24 07:41:28: MQTT publish: topic 'zigbee2mqtt/bridge/log', payload '{"message":{"friendly_name":"0x00124b002a5d2e2a"},"type":"device_connected"}'
Zigbee2MQTT:info  2023-12-24 07:41:28: Starting interview of '0x00124b002a5d2e2a'
Zigbee2MQTT:info  2023-12-24 07:41:28: MQTT publish: topic 'zigbee2mqtt/bridge/event', payload '{"data":{"friendly_name":"0x00124b002a5d2e2a","ieee_address":"0x00124b002a5d2e2a","status":"started"},"type":"device_interview"}'
Zigbee2MQTT:info  2023-12-24 07:41:28: MQTT publish: topic 'zigbee2mqtt/bridge/log', payload '{"message":"interview_started","meta":{"friendly_name":"0x00124b002a5d2e2a"},"type":"pairing"}'
Zigbee2MQTT:error 2023-12-24 07:47:28: Failed to interview '0x00124b002a5d2e2a', device has not successfully been paired
Zigbee2MQTT:info  2023-12-24 07:47:28: MQTT publish: topic 'zigbee2mqtt/bridge/event', payload '{"data":{"friendly_name":"0x00124b002a5d2e2a","ieee_address":"0x00124b002a5d2e2a","status":"failed"},"type":"device_interview"}'
Zigbee2MQTT:info  2023-12-24 07:47:28: MQTT publish: topic 'zigbee2mqtt/bridge/log', payload '{"message":"interview_failed","meta":{"friendly_name":"0x00124b002a5d2e2a"},"type":"pairing"}'

Update 2023-12-26
Out of curiosity, I today tried to pair a fresh TV02-Zigbee with the Conbee III using Zigbee2MQTT.

This worked flawless. So I see my base setup as confirmed to work OK.

Perhaps this PR will help you ?

Hi all,
I am also having exactly the same issue.
My setup is similar to what @raoulbhatia described. Additionally I also tested with deCONZ 2.25.0-beta, also no success pairing the SNZB-02 with Conbee III.
Today I successfully paired IKEA Tradfri plugs and repeater without issues via Zigbee2MQTT.

The PR will be merged in the v2.25.1

Could be related to the following:

The upcoming v2.25.1release updates deCONZ to apply the same classic join mechanism for ConBee III as the ConBee II does and also to allow to pretend to some devices being the original manufacturer gateway, since some devices behave differently wherever they think they join the vendor gateway or a 3rd party one. Note this also requires a small addition in the ConBee III firmware which should be out soon.

1 Like

Thanks @manup – looking forward to the new firmware release :smiling_face:


i have the same Problem, i can not connect a Aqara Temp Sensor (WSDCGQ11LM) to the Conbee 3.
I hope to get i work with the new Firmware release (now im using 0x264e0900).
Can you tell us a ETA?

Hi there - same for me. brand new ConBee III. Latest FW deCONZ_ConBeeIII_0x264e0900.bin.GCF flashed. Two Aqara Windows / Door sensors - listed as compatible - are not paired. tried on Windows 10, Raspi OS ans Mac OS - that really sucks! Any solutions!?