DDF for Tuya YG500A Smoke Detector?

Hello, I just got me a Tuya Smart Zigbee Smoke Detector, Model PST-YG500A
It is not shown in the Phoscon App nor in API, does anybody know how to connect this device?
Does anybody have DDF for this device or advice how to get it working?
Server: Raspberry 3+, Debian bookworm with fhem home automation running, Deconz ConBee II

Thank you and kind regards,

Please open a device request on GitHub with the correct screenshots

Opened new device request - I am not sure, if I submitted all the needed Information correctly, since this is just very, very new and obscure to me.
Looking forward to hearing from you / the support…

Hi @flow_ld
you can crosscheck with my DDF file for YG400A

Hi @Siggi , thanks for helping out. I have to admit, I am really new to all this stuff and I don’t know what to do with the ddf.
I tried to access the device with my ConBee II connected to my PC (instead of my Raspi, where it usually runs) but don’t know how to extract the necessary information.
Unfortunately, it won’t establish a connection to my zigbee network. Just a few seconds after I enable “Join network”, it would crash. Tried it several times, no luck.

How can I try the ddf for your device (YG400A)?

When adding it to your pc you need to re pair the device. Nothing is stored on the Conbee.

When I use the ConBee II with my PC, start the deconz software and connect to the ConBee II, it begins to show the stick (in blue) and starts to show other devices (in yellow). Unfortunately, the app crashes after a few seconds, before I can read any information.
What do I need to do differently?

If someone could tell me how to try the ddf for the YG400A (what do I do with it?), I would be glad to try and post results.

Deconz now up and running. I had to uninstall it and reinstall it - now it has not crashed since.
here are the devices showing up so far - no smoke sensor of course.

What do I do now? How can I read the smoke sensor, if it won’t show up?

I managed to load the ddf for Tuya smoke sensor YG400A, here it shows in deconz:

does this help?

the smoke sensor is recognized in Phoscon App as YG400A. I was able to pair it and realized that the symbol flickers every time I push the small button. It does not serve as a sensor for automization though and does not deliver any useful state, trigger, action…
Does anybody know how to get this piece working?
Since I would like to use it in fhem home automation, it should at least deliver its status, alarm trigger and a possibility to activate or deactivate the sirene.
thank you in advance!

Please stick to the GitHub issue, to determine its missing device support.

Posting in 2 places is confusing.

1 Like