Connect ECONNEFUSED error

I would certainly appreciate assistance on this issue.

I installed Node Red on my Windows 10 pc and have been using deCONZ successfully for home automation. All the temperature sensors installed around the house stopped working (i.e., the deCONZ in nodes all have red dots). These temperature sensors are using the Phoscon gateway with ip address I noticed that node red is throwing the following error.

28 Nov 14:58:53 - [error] [deconz-server:Phoscon-GW] WebSocket error: Error: connect ECONNREFUSED
28 Nov 14:58:53 - [warn] [deconz-server:Phoscon-GW] WebSocket disconnected: 1006 -

At first, based upon posts I read, I thought it might be a firewall problem. So, I went into Windows Defender Firewall and creating both inbound and outbound rules that specifies connections to TCP ports 443 and 1883. This did not cure the problem.

Could someone with knowledge in this area please suggest a possible solution?

Thank you.

Could be that the Websocket port is wrong. The correct port can be obtained via the REST-API /config endpoint as described in Websocket - deCONZ REST-API.

As alternative it can also be specified as command line parameter to deCONZ like:

deCONZ --ws-port=9090

Thank you for the reply and suggestion.
When I look at the deCONS input node and inspect the settings that were fetched, I see that is lists WebSocket Port 443. Does this demonstrate that the correct port is being used?
Again, your assistance is most appreciated.


To correct this problem i edited the deCONZ in node by deleting all the Properties (Port, API Key, WebSocket Port and Polling, sec) and then used Auto fetch to repopulate this data anew. Now, I see WebSocket Port 8088 is being used instead of 443 and I have a new API Key.

Thanks again for the assistance!