ConbeeII firmware shows "not connected"

Hi everyone,

I had a Conbee II working with DeCONZ over the past few months. Everything worked fine. Today I opened the Hue Essential app and it told me, that there is an update for DeCONZ, I clicked install and then it stopped working. My DeCONZ is now on version 2.21.02 (Debian). I updated the Conbee II firmware on Windows to the latest 26780700. Got a SUCCESS message. Plugged it into my Debian machine again but still it shows “Firmware: not connected” and requests return:

[{"error":{"address":"/lights/2/state/on","description":"Internal error, 951","type":901}},{"error":{"address":"/lights/2/state/xy","description":"Internal error, 951","type":901}}]

I also tried to reinstall DeCONZ and I rebooted the machine.

Hi can you share some logs?

In #deconz you can find out how and what logs.

Please find attached the log from DeCONZ:

Please add a full log and use pastebin please.

Run it for a few minutes and pasted it into pastebin. Edited my original post above with the link to it.

Please let me know if you need a longer period than what I’ve collected now.

No its fine :slight_smile:

I believe the firmware update somehow failed

Can you update the firmware ?

Thanks for your help.

When I try to update the FW of Conbee II on my Debian machine I get this:

$  sudo GCFFlasher_internal -t 60 -d /dev/ttyACM0 -f /home/tmsplntr/deCONZ_ConBeeII_0x26780700.bin.GCF
GCFFlasher V3_17 (c) dresden elektronik ingenieurtechnik gmbh
retry, failed

But ttyACM0 is available:

$ ls -la /dev/ttyAC*
crw-rw---- 1 root dialout 166, 0 Jun  4 10:50 /dev/ttyACM0

If I do it on Windows it’s successful. I don’t have the log at hand right now but at the end the flasher tool wrote:


And how does it look in Linux after updating ?

After I updated Conbee II on Windows to the latest FW it looks exactly like I described in the first post. It says “Firmware: not connected”. Also the log I shared here is from Linux after I successfully updated the firmware on Windows and connected Conbee II back to my Linux machine.

Updating the FW of Conbee II on Linux is not possible in my case. It always says:

$  sudo GCFFlasher_internal -t 60 -d /dev/ttyACM0 -f /home/tmsplntr/deCONZ_ConBeeII_0x26780700.bin.GCF
GCFFlasher V3_17 (c) dresden elektronik ingenieurtechnik gmbh
retry, failed

Looks like this might be in play

Indeed. I realized before that /dev/serial/by-id was missing on my system. But I didn’t know that DeCONZ actually uses it. I thought it was more for debugging purposes.

I created the 60-serial.rules file which was missing (systemd/60-serial.rules at main · systemd/systemd · GitHub) and triggered the rule like described here: Reddit - Dive into anything

After that I restarted the deconz service and now everything is working fine again.

Thanks a lot for your help! Very much appreciated.

1 Like