Conbee III on deCONZ stable?

I got my Conbee III but I wonder if it’s already compatible with the stable 2.23.x version. According to the Changelog on GitHub support was added with 2.24 beta.

The Conbee III is supported starting deconz beta 2.24.1. Older version do not support the Conbee III.

Any ETA for 2.23 stable?

Next stable should land soon.

I’ve found better way to setup the baudrate. By executing the following (just copy paste to terminal and press enter).

echo ACTION=='"add"', SUBSYSTEMS=='"usb"', \
             ATTRS{product}=='"ConBee III"', \
             RUN+='"/bin/stty -F /dev/%k 115200"' | \
             sudo tee /etc/udev/rules.d/99-conbee3.rules

This rule automatically sets the baudrate on boot and hot-plug.
I’m updating the docs now to include this step.

It does not work.

[3021009.026663] usb 1-1.4: new full-speed USB device number 8 using dwc_otg
[3021009.195608] usb 1-1.4: New USB device found, idVendor=0403, idProduct=6015, bcdDevice=10.00
[3021009.195628] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[3021009.195644] usb 1-1.4: Product: ConBee III
[3021009.195659] usb 1-1.4: Manufacturer: dresden elektronik
[3021009.195674] usb 1-1.4: SerialNumber: DE03110752
[3021009.204905] ftdi_sio 1-1.4:1.0: FTDI USB Serial Device converter detected
[3021009.205110] usb 1-1.4: Detected FT-X
[3021009.209146] usb 1-1.4: FTDI USB Serial Device converter now attached to ttyUSB1
pi@raspberrypi:~ $ ls -l /dev/serial/by-id/usb-dresden_elektronik_ConBee_III_DE03110752-if00-port0
lrwxrwxrwx 1 root root 13 Nov 15 08:28 /dev/serial/by-id/usb-dresden_elektronik_ConBee_III_DE03110752-if00-port0 -> ../../ttyUSB1
pi@raspberrypi:~ $ GCFFlasher_internal -l
GCFFlasher V3_17 (c) dresden elektronik ingenieurtechnik gmbh
Path             | Vendor | Product | Serial     | Type
/dev/ttyAMA0     | 0x0000 | 0x0000  |            | RaspBee
/dev/ttyUSB0     | 0x0403 | 0x6001  |            | Generic FTDI
/dev/ttyUSB1     | 0x0403 | 0x6015  | DE03110752 | ConBee
pi@raspberrypi:~ $ stty -F /dev/ttyUSB1 115200
pi@raspberrypi:~ $ deCONZ

Can you please check the output of stty -F /dev/ttyUSB1 it should show the baudrate is set to 115200.
Note the above code snipped gets only active after reboot or unplug / reattach the dongle.

There seems to be another FTDI based device attached as well (ttyUSB0), could it be that some other software tries to connect here?

I added the udev rule, just wanted to make sure its set - thats why I did the ssty command manually.

pi@raspberrypi:~ $ stty -F /dev/ttyUSB1
speed 115200 baud; line = 0;
-brkint -imaxbel

The other USB Device is a Technische Alternative D-Logger. I run the software that uses it manually and it uses ttyUSB0 correctly.

what can I do?

I am afraid there is nothing you can do but wait for a working and stable release.

Should you upgrade?

I’m all for the “don’t fix what ain’t broke” viewpoint, so I believe this also applies here. If you have the Conbee II and everything works as it should, **there is no reason to upgrade right now.

Can please anyone from Dresden Elektronik confirm I bought another (after the Hive) hardware with beta software? This is not a real drama, but I want to know if it can run with stable deCONZ (the udev does not work for me) or if its better to wait until 2.24 becomes stable. And please give me an ETA for 2.24 if that is the case.

Other question: can I check if the ConBee III works correctly without running deCONZ? So I could check without having to import my backup if it will not work.

I know for a fact that Stable is expected today or at least within upcomming week.


Right stable version is currently baking, takes a few hours until everything is compiled.

Other question: can I check if the ConBee III works correctly without running deCONZ? So I could check without having to import my backup if it will not work.

Easiest option is to run deCONZ on a other machine like Desktop PC with v2.24.1-beta.
Otherwise GCFFlasher4 can be used for a quick check as well:

For example on a Windows PC with standalone GCFFlasher4

Unzip and in a terminal (cmd via start menu) go to the path where the .exe is (here C:)

cd c:\

GCFFlasher -l

GCFFlasher -d COM3 -c

The -l options lists the COM port on which ConBee III is connected, for example mine is on COM3.
The -c option is “connect” and will just connect to the firmware and print out commands received/send to the firmware.

1 Like

Will the stable release will support raspberry pi1/zero ?

Updated to 2.24.2 on saturday. Just switched the Conbees. No problem at all.

Next time just tell the people the software is not yet ready / still in beta. That had saved me my Homebridge setup.

1 Like

Is your ConBee 3 actually shown as a ConBee 3 in Phoscon and Deconz?

In my case Phoscon shows it as a ConBee 1 and Deconz still shows my ConBee 2…

1 Like


But it’s shown as Conbee II in

pi@raspberrypi:~ $ GCFFlasher_internal -l
Path              | Serial      | Type
/dev/ttyUSB1      | _DE03110752 | ConBee_II
1 Like

Nice. I’m glad it’s working for you

Ok, Installed deConz on a windows Laptop and was able to get the API Key.
Shutdown the home server and replaced the Conbee II by the Conbee III stick.
Uploaded the backup and everything came on line.

Changed the API key in Domoticz, but that did not work, error, error, error.
Replaced the new API Key with the old API Key and all worked again in Domoticz.
Strange, but fine with me.

Uploaded the backup and everything came on line

The backup from the windows machine ?
Because the API key is specific to the host you are getting it.
And you can switch Conbee without changing API key.