Conbee III API Key

Hi, received the Conbee III last week and started testing.
My home server is running and I do not want to play with that server.
Getting into the deConz is already hard, but getting an API Key is impossible.
I have tried an other Conbee II stick and I get an API Key.
After rebooting and using the Conbee III stick Nothing,
Yes, I have used the authentication app button.

  • {*
  • “error”: {*
  •  "address": "/",*
  •  "description": "unauthorized user",*
  •  "type": 1*
  • }*
  • }*

Hello, how are you doing to get the key ? Getting Started - deCONZ REST-API

curl http://IP:PORT/api/ -X POST -d '{"devicetype": "TestKey"}'

As the manual:

The Conbee II replies correcly, the Conbee III is giving the error.

Ha ?
Strange it depend of the API, not the device.
I have made a try on my side with the conbee 3, without using the “magic button”

    "error": {
      "address": "/",
      "description": "link button not pressed",
      "type": 101

And with it

    "success": {
      "username": "B031A5B46D"

If you don’t want to break your dev machine, can make a try on a windows machine, you can have 2 deconz instance on different machine, if you haven’t cloned your gateway yet (different MAC adress, zigbee key, ect …)

I have tried this on 2 Ubuntu machines, both the same reply.
The first answere I get as well. “link button not pressed”
When you go for the API Key, “unauthorized user”,*

Does not make sense,

P.S. deConz works only with the Conbee III stick when you boot with the stick.
Stopping deConz and restarting will not work. Not really stable.

Ha? Go to know haven’t tested that on my side yet, but the code is moving ATM.

About your issue, you have tried on 2 machines, and it work whith the same manipulation on the conbee 2 ?

You can try just with switching key ? without rebooting deconz ? Because this is only handled with the API, there is no reason for the code make something different according to gateway. I m seeing only 2 possiblities : authentification on phoscon (I had this issue too for other thing and need to disconnect/reconnect on phoscon), or deconz is not running on the not working test (due to conbee 3).

1 Like

I have been able to get the API Key, Windows machine.
However, the new api key did not work, the old one did work.
After running the linux (Ubuntu) and the Conbee III stick for a few ours.
The system was getting corrupted.
More and more hardware was loosing there connection and switches did not work any more. (Wife angry)
Domoticz was gettinng confused as well, the light brightens was incorrect.
For that reason, I had to go back, a part of the central heating system is running on deconz and Domoticz.
The risks are too high, it is freezing here.

Returned to the Conbee II stick and used the backup. All is running well again.
Very strange, that the new III stick can mess-up the software.

Wich one deconz version are you using ATM ?

Have you tried to update the device firmware (for the conbee 3) ?
I m not sure but if deconz have connexion issue, you can have error if you use the API in same time.

It can explain yous strange issue + stability issue.
Even if for me the conbee work or does’t work, and can’t work 1 time and not after a reboot.

Are you using an USB extention ? I have just migrated from conbee1 to conbee 3, the conbee 1 have worked 4 years without the USB cable but the conbee 3 need it.

Presently I use : Ubuntu 20.04.6 LTS (small home server with some other software, Domoticz and Pihole)
The Conbee III has been updated to: ConBeeIII_0x26450900.bin.GCF)
I can update the stick again, however, No error where displayed when updating the Conee III.
Presently, everything is running correctly with the Conbee II stick. (luckily, no permanent damage)
Will come back, after updating the stick, etc.

P.S. I use an USB 2 extension cable as advised. (specially purchased)
Updated the Conbee III again. (no issues flashing the stick)
I noticed a small thing, see the picture below.
Model Identifier Conbee II
Screenshot from 2023-12-03 11-01-00

After playing with the Conbee III, updating and checking the deConz connection.
The Running Conbee II was gettin issues, some plugs and a switch where not connected any more. I could not repair what was broken. Had to use the restore function again.
Very strange that the Conbee III is able to interfere with the other network.

Ha yes I have found the firmware deCONZ_ConBeeIII_0x264d0900.bin but this one is removed from the Dresden website, they probably have issue with it.
So the only one available ATM is the one you are using.

So on your test, you are using the same deconz instance, using conbee 2 no issue, switch to conbee 3, then return to conbee 2 and have issue ? Restart not working, need to use the restore feature ?

On my side If I try to update attribute on node information, I have “Conbee 3” displayed (Conbee 1 before, it’s not updated, even after some restart, need to force a read attribute)

I Think we have to wait, the Conbee III is not stable for this moment.
We will see when there is a new firmware available, than we can continue.

The strange things is that the Conbee III is able to interfere with an existing network.
I have played many time with MQTT and this had never any influence on the existing running network.

The strange thing, the most stable items where effected, like the OSRAM plugs, I have them for years and they never gave an issue. running the Conbee III made them in stable and they lost the connection.
The same for the Philips switches, they always work, but not with the Conbee III.
Every time deconz found a new switch, the same as before, time after time.

I will wait for the new firmware and continue than again.

Sadly after some time one of my plugs lost its connection and after that the routine.
Reconnected the plug again and repaired the routine, but after some time the plugs lost connections again.
Reconnected again and repaired the routine, but again the plug was lost.

Time to get back to the Conbee II, The new Conbee III with the new firmware is not stale yet.
We have to wait for a newer firmware again. (third time right)

API keys are stored in the backup / database so thats fine :slight_smile: