Conbee II not working after raspberry update

I updated my raspberry pi 4 buster to bullseye. Existing sensors not getting updated anymore. At first it seems they updated once after reboot or randomly after several hours, but currently there was no update for 24 hours. I can not control lights and I can not pair new devices.

already googled and tried:

I purged and reinstalled deconz
I loaded older zigbee configuration (alt-click advanced)
I updated firmware and version to 2.19.03 / 19.9.2022 Firmware 26780700
I reset the gateway

Dont know what else I can try. Its a headless raspian with iobroker and deconz.

I just restored the old buster image and everything is working. I can pair new devices, can switch lights and get sensor data. (cloned the sd-card before the update)

pi@iobroker:~ $ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 019: ID 1cf1:0030 Dresden Elektronik ZigBee gateway [ConBee II]
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

pi@iobroker:~ $ groups pi
pi : pi adm dialout cdrom sudo audio video plugdev games users input netdev spi i2c gpio iobroker

pi@iobroker:~ $ ls -l /dev/ttyACM*
crw-rw---- 1 root dialout 166, 0 Dec 14 17:15 /dev/ttyACM0

What can I do to fix the bullseye installation?

I loaded older zigbee configuration (alt-click advanced)

This is just the network config, not the device database

Have you tried to make a backup/restauration of your zigbee network using the phoscon backup/restore feature after having installed a clean deconz version ? (BTW ATM better to use 2.18.X version)

Yes I reset the gateway, uninstalled deconz and tried to start from scratch as well as importing the backup afterwards. Under no circumstances I could add a new device or get connection to existing ones.

Just tried again without luck.

Reset gateway, apt purge deconz and apt autoremove, then restarted pi. installed deconz and I can still not add a sensor. importing phoscon backup doesnt help :unamused:

Ok so I don’t have more idea.
Need to take a look in logs Debugging 101 · dresden-elektronik/deconz-rest-plugin Wiki · GitHub

Thanks for your input. I reset the system and start from scratch…

Take a look in logs first (it’s possible on desktop or headless OS), you will probably see an error message. And I m curious because I don’t see what can be the problem.

You are right, after reset it still didnt work. I installed deconz on a windows machine and had a look at the debug log. There was an errror message that ext pan ID = xxx instead of 0 (If I recall correctly)

I set the ID to match the error message and the issue was resolved. I still dont know why the setting was wrong. I never messed with those values on purpose.