ConBee 2 and openHAB 3 in Docker on RP4 keeps Initializing

  • Platform information:
    • Hardware: Raspberry Pi 4
    • OS: Raspberry Pi OS / x64 / 11 (bullseye)
    • Java Runtime Environment: 11.0.15 (Temurin-11.0.15+10) (running in Docker)
    • openHAB version: 3.3.0 (running in Docker)
    • ConBee 2 USB stick

Dear community,

I’m completely new to the field of home automation and making my very first steps. My goal is to control some Philips Hue Smart Plugs via ZigBee.

As you can read in the platform information, I’m running openHAB 3 on my Raspberry Pi 4 via Docker. For this I’ve created a dedicated openHAB user called myopenhabuser on the host that is used for the Docker container.
I can successfully access openHAB’s UI via http://myRaspi:8080.

I’ve bought a ConBee 2 USB stick as ZigBee gateway. When plugging-in the stick, I can successfully see it as /dev/ttyACM0. Then I’ve executed sudo usermod -a -G dialout myopenhabuser and restarted the openHAB Docker container with the following command:

docker run --name openhab \
  --net=host \
  -v /etc/localtime:/etc/localtime:ro \
  -v /etc/timezone:/etc/timezone:ro \
  -v /opt/openhab/conf:/openhab/conf \
  -v /opt/openhab/userdata:/openhab/userdata \
  -v /opt/openhab/addons:/openhab/addons \
  -v /opt/deconz:/opt/deCONZ \
  -d \
  -e USER_ID=999 -e GROUP_ID=994 \
  -e CRYPTO_POLICY=unlimited \
  --restart=always \
  --device=/dev/ttyUSB0 \

I can still access http://myRaspi:8080. After installing the deCONZ binding, I’m adding a deCONZ-Gateway with the following settings:

  • IP address: myRaspi
  • HTTP port: 8080
  • API key: the 16 digit Install Code that was printed on the ConBee’s packing.

And now the status is stuck in INITIALIZING.

Any help would be really appreciated :slight_smile: thx a lot in advance!

IDK for the rest, I never use docker, but the deconz api key is a key generated by deconz.
For exemple Getting Started - deCONZ REST-API

IDK if you have a procedure using OpenHAB else I can give you a Curl request, but on the Help page there is written “Authorization API key (optional, can be filled automatically)” cf Dresden Elektronik deCONZ - Bindings | openHAB

and if http://myRaspi:8080 is an OpenHAB page it can’t be the deconz Url/port, can be the same IP/HOST but not possible it’s the same PORT

How work OpenHAB on docker, you need to install a deconz docker, or you have a “deconz plugin” to install it inside the OpenHab docker.

Okay, now I used 8081 as port and left the API key field empty, leading to the following error:

COMMUNICATION_ERROR Connection refused 

But you need a api key can try with curl

curl http://IP:PORT/api/ -X POST -d '{"devicetype": "TestKey"}'

Can try http://IP:PORT/api/XXXXXX/config this url need to work, with few line because the API key is bad, but you need to have a result.

Thank you for your help, I really appreciate!

What I don’t understand: which port do I have to use for this command? OpenHAB is running on port 8080,so probably not that one. I think it should be some port of the ConBee stick, right? But where do I find this port number?

You need to use the same port and same ip used to acces phoscon (in local, not external)
You can have them here too

Here you can find the solution