Communication lag - raspbee II


I am having a weird problem with my setup.


  • raspberry 4b 4gb
  • raspbee II - 26780700
  • phoscon 2.19.03 (but I had the issue also with previous versions)
  • homeassistant 2022.12 (but I had the issue also with previous versions)

I am experiencing a weird problem where sometimes my homeassistant automations don’t start straightaway (i.e. light do not start), but only after a few seconds. It seems that the communication between the devices and phoscon get stucked for a few seconds (sometimes a couple of seconds, sometimes also 30 seconds), and then it get played after it get un-stuck. This has been happening since the last month or so.

Note that when there is this problem, nothing works, not just one light.

Example: I enter a room, nothing happens (even though light should turn on), I go away, from another room I see the light turning on after some time, even if I was in the room 30 seconds ago. So the message is sent eventually, but there’s lag.

what I tried:

  • enable logs in phoscon, cannot see anything clearly wrong. A few times when the problem happened I ran to look at the logs and I can see that there is “stuff happening”, even though I am unclear of what the log messages mean, I can see that there’s communication with the devices.
  • update phoscon to latest version (I am having this problem with at least the last 2 versions)
  • update homeassistant multiple times to latest version
  • change zigbee channel
  • change home router to 5ghz only
  • disable bluetooth and wifi on raspberry
  • update python to 3.11
  • move raspberry in different rooms of the house
  • replace sd card
  • restart phoscon. When restarted everything works again.

I am not sure what else to try to fix this!

Does anyone have any idea of what to try next?

I am going to post logs as soon as it happens again.

Thank you.

it just happened, here’s the pastebin: 21:26:42:691 APS-DATA.confirm request id: 84 -> erase from queue21:26:42:693 r -

I can see a bunch of 0xE9 happened this time, what would this mean? bad network?

not necessarily Zigbee Error Codes in the Log · dresden-elektronik/deconz-rest-plugin Wiki · GitHub

But honnestly the 2.19.3 save issue from 2.19.X but was not perfect, if you can make a try with a 2.18.X version ?

thank you for your reply, I will try with the latest 2.18 and let you know.

Hope I am not talking too soon, but with 2.18.02 everything works seamlessly since yesterday! I was expecting the problem to have already happened as it was happening multiple times per day.

I’ve seen another thread where people are lamenting similar issues, which I can’t find anymore now :frowning: it was talking about groups being slow to trigger, I think what I am experiencing is something similar.

I think the pastebin I have posted above is a red herring as, when the problem was happening, most of the times there were no errors at all in the logs.

Can I do anything other than what I’ve already done to help diagnose the issue with 2.19.x? Seems I am stuck with 2.18.02 forever otherwise.

Thank you for your help.

I can confirm after 3 days that the problem is not happening on 2.18.02, and was constant in all 2.19.x.

What should I do to raise this? I don’t think I have a particular setup and I’ve really tried anything that I could to make sure it’s not something specific to my network.

I have dev experience, I could also try to build 2.19.x branches but without some PRs, to isolate what is causing the issue, if this helps?

There’s already a GitHub issue open :slight_smile:

1 Like

When tested with 2.20, can you share some new logs and what change in behavior your noticing. I had no issues anymore after going to latest stable. Additionally, a screen of your deCONZ map. A

I need to apologies, the delay problem I saw with 2.20 was caused by a misbehaving motion sensor. All seems to be fine with 2.20.0 now.

1 Like