Can't see ConBee II stick any more

ConBee II stick
Debian bullseye + kernel 6.0
Deconz 2.19

Deconz won’t see the stick any more since a reboot.
I know the stick is there:

Nov 06 16:03:10 server kernel: usb 2-1.6: new full-speed USB device number 5 using ehci-pci
Nov 06 16:03:10 server kernel: usb 2-1.6: New USB device found, idVendor=1cf1, idProduct=0030, bcdDevice= 1.00
Nov 06 16:03:10 server kernel: usb 2-1.6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Nov 06 16:03:10 server kernel: usb 2-1.6: Product: ConBee II
Nov 06 16:03:10 server kernel: usb 2-1.6: Manufacturer: dresden elektronik ingenieurtechnik GmbH
Nov 06 16:03:10 server kernel: usb 2-1.6: SerialNumber: DE2126390
Nov 06 16:03:10 server kernel: cdc_acm 2-1.6:1.0: ttyACM0: USB ACM device

My user is in the dialout group.

If I start with
deCONZ --dbg-info=2 --dbg-error=2
there is some startup output but this seems to be the main thing, repeated every few seconds:

19:27:41:641 COM: /dev/ttyACM0 :  (0x8086/0x1C26)
19:27:41:642 COM: /dev/ttyS0 :  (0x0000/0x0000)
19:27:42:650 COM: /dev/ttyACM0 :  (0x8086/0x1C26)
19:27:42:651 COM: /dev/ttyS0 :  (0x0000/0x0000)
19:27:43:643 COM: /dev/ttyACM0 :  (0x8086/0x1C26)
19:27:43:643 COM: /dev/ttyS0 :  (0x0000/0x0000)
19:27:44:642 COM: /dev/ttyACM0 :  (0x8086/0x1C26)
19:27:44:642 COM: /dev/ttyS0 :  (0x0000/0x0000)
19:27:45:641 COM: /dev/ttyACM0 :  (0x8086/0x1C26)
19:27:45:642 COM: /dev/ttyS0 :  (0x0000/0x0000)

ttyACM0 is the correct device, ttyS0 is not. I am not sure what those hex IDs are there? They don’t match the VID/PID of the ConBee.
I have been using ConBee II + deCONZ + Aqara temp sensors for 3+ years without issue, until today.
Is there a way to test ttyACM0 to make sure it’s alive?


Can you share logs with info,info l2, error ,error l2, aps ,aps l2?

Did you put th levels as i asked?

I thought this was in the first line of the paste, sorry,
deCONZ --dbg-aps=2 --dbg-info=2 --dbg-error=2

I am not sure what’s going on

I suggest trying this :

Whatever the problem is, the flasher can’t see it either. I will try in another PC.
After about a minute:

20:45:15:620 parse commands: /usr/bin/GCFFlasher_internal.bin -t 60 -d /dev/ttyACM0 -f deCONZ_ConBeeII_0x26780700.bin.GCF -x 3

20:45:15:620 using firmware file: deCONZ_ConBeeII_0x26780700.bin.GCF
20:45:15:650 ls dev: /dev/ttyACM0 (0x8086/0x1C26) sn:
20:45:15:650 ls dev: /dev/ttyS0 (0x0000/0x0000) sn:
20:45:15:650 device /dev/ttyACM0 not found
retry, failed

Works instantly in my desktop, all sensors online immediately. Grr. Must be a problem with the server, somehow.

In that case, perhaps not enough power ?

Tried different USB ports, different USB extension, behaves the same.
I will try some other USB devices in there and see if they are working normally.
I needed a new server anyway…

Plugged in an RTL DVB stick and ran rtl_433 for a bit. Definitely more power-hungry than the ConBee II and this is working fine. So not a hardware issue with either the server’s USB ports or the ConBee.
I happen to have an Ubuntu 22.04 VM running on here and passing through a USB device is literally as easy as ticking a box. And yes, deCONZ works absolutely fine when ConBee is passed through to the guest.
So we are back to a software issue on the host but which of the below?
Changes since it last worked:

  • installed docker
  • installed apparmor userspace tools to satisfy docker
  • new kernel: 6.0.2-1+b1 upgraded to 6.0.6
    My guess would be the kernel version.

Is there any tool that is not deCONZ that I can test the ConBee II with? eg does it behave like a serial device I can send commands to with putty?