Cannot connect Hama Thermostat TS0601

Hello, i recently bought three Hama Smart Thermosat (TS0601) Devices .
The main reason i selected this model was, because i have seen from multiple sources that they are supposed to work fine with deconz.

Currently i am using the RaspBee on a Pi that runs Raspbian GNU/Linux 10 (buster).
Deconz version is v2.19.3-beta

I Tried to connect the device for the last 3 days and i just cannot get it to work.
I have found this issue and even there most people seem to be able to connect:
GitHub Issue

I tried to do the pairing twice, without deleting the node.
I cloned, build and replaced the newest master for the REST Plugin … but no luck.
The device itself is shown in the deconz-app, but it is not included in the REST-Api result at all. ( i am aware that thermostats won’t be shown in the phoscon app)

Is there anybody that can give me a helping hand, as there seem to be multiple people that managed to do it?
Maybe someone has a compiled version of the rest plugin that works with this themostat?
Most of the branches from the above mentioned issue are long gone and supposed to be merged.

Can someone tell me what they did to connect this thermostat?
If you need more info i will be happy to provide any logs or information that helps.

Greetings and thanks in advance!


It’s not supported at this point: Hama Smart Radiator _TZE200_h4cgnbzg · Issue #6635 · dresden-elektronik/deconz-rest-plugin · GitHub

Is the active issue for that.

Good to know that it is nothing that i am doing wrong.
Still weird, because it seemed to be supported in the past according to older issues and posts in other forums.

As far as i can tell, your device ( h4cgnbzg) has never been supported or working before.

Your TS0601 is a Model ID from Tuya, but Tuya’s definitions are done by Manufacturer name. That being said: Your TS0601 is a different one than you might have seen before.

1 Like

Hi, I have the same problem now. But the thing ist, that I have already 6 Hama TRV working. But I can’t add more of them and I don’t now why. Some weeks ago with my first 6 Hama TRV’s it worked with no problem. I ordered two more and now they show that they are paired but doesn’t appear in Home Assistant. What can be the reason for that?

Different chip probably.

Maybe you are right. I found out, that the ones that work are “V2”. The new ones are “V3”. The V2 seems to work with deCONZ. I use them in combination with better Thermostat since many weeks. So if some one has the same issue, check the version that is written on the TRV.