Can not update deConz on Raspi

Hi,

I run a ConBeeII on a Raspi, Deconz Version 2.10.00 and Firmware 26660700
All is fine, but I am not able to update.

This is what I am doing on the raspi:


Err:3 http://phoscon.de/apt/deconz buster InRelease
Could not connect to phoscon.de:80 (144.76.96.194). - connect (113: No route to host)

My post is not very instructive, because I am only allowed to send 2 links, please contact me for the whole log.

Thank you, Bernhard

Are you using any network firewalls?

Hm, I got some findings.

The rapsi can do ethernet-services like ping with ipv6, but not with ipv4.
Strange enough, but surely no deConz issue.

You have an idea what is wrong anyway?

Thank you, Bernhard

Not sure, I’m not a Linux guru myself :sweat_smile:. Perhaps your router not giving ipv6?

I see, /etc/dhcpcd.conf and /etc/networks/interfaces was written by deconz to allow wlan0 as stand-alone interface (I see ‘generated by deconz’ in the files
Is it possible that this caused the problems?
I do not need the stand-alone wlan.

regards, Bernhard

Not in this case. The update you try to run is not managed by deconz but by the os.

Yes, you are right, but deConz set up some of the suspicious config files.

That’s because deconz can control the wifi iirc.
@de_employees can explain that probsbly.

You can disable wifi in the Phoscon App → Settings → WIFI

But I don’t think thats the problem. Perhaps the phoscon server was down. Did you re-tried the update at a later time?

If not: did you configure some of the network settings of the RPI on your own?

etc/network/interfaces should contain the line: iface eth0 inet manual
Thats pretty much it.

etc/dhcpcd.conf is only needed if you want to have a static ip.

Another idea: you can also configure network settings via RPI Desktop. Right click at the to arrows at the right top corner. Check “Automatically configure emtpy options” is all thats needed on my RPI.

And do apt update first before apt install …

1 Like

Wifi is disabled, but in the past I did some tests with it.

I definitely can not access any external IPV4 address, so it was not the phoscon server that was down. I got the same message when I ping 8.8.8.8, but it is ok for raspbian.raspberrypi.org, which is resolved to a IPV6 address

/etc/network/interfaces looks as you said…

Another idea: you can also configure network settings via RPI Desktop. Right click at the to arrows at the right top corner. Check “Automatically configure emtpy options” is all thats needed on my RPI.
I have a headless RPI, so that does not work for me.

And do apt update first before apt install

sure…

OK, found it, I had a bridge configured during my experiments…

Thank you for your support!