Busch Jäger Probleme

Yes, this is helpful thanks.

And just to be sure; your automations did not work this time right?

Hi together

if you look into my starting message from January 4th, it shows the info already, but I have used a different way to get it (out of the APP started on PI - not the Web Client).

But I see the approach shown now looks easier. Expectingly, the button 1 and 2 are not sending anything into the Zigbee, as those are controlling exclusively the wired lamp connected, but button 3-8 are giving following response:

                {
"19:38:43:459": {
    "e": "changed",
    "id": "16",
    "r": "sensors",
    "state": {
        "buttonevent": 3002,
        "lastupdated": "2024-05-13T17:38:43.340"
    },
    "t": "event",
    "uniqueid": "d8:5d:ef:11:a1:00:45:de-0b-1000"
},
"19:38:45:569": {
    "e": "changed",
    "id": "16",
    "r": "sensors",
    "state": {
        "buttonevent": 4002,
        "lastupdated": "2024-05-13T17:38:45.427"
    },
    "t": "event",
    "uniqueid": "d8:5d:ef:11:a1:00:45:de-0b-1000"
},
"19:38:47:415": {
    "e": "changed",
    "id": "17",
    "r": "sensors",
    "state": {
        "buttonevent": 5002,
        "lastupdated": "2024-05-13T17:38:47.386"
    },
    "t": "event",
    "uniqueid": "d8:5d:ef:11:a1:00:45:de-0c-1000"
},
"19:38:49:216": {
    "e": "changed",
    "id": "17",
    "r": "sensors",
    "state": {
        "buttonevent": 6002,
        "lastupdated": "2024-05-13T17:38:49.178"
    },
    "t": "event",
    "uniqueid": "d8:5d:ef:11:a1:00:45:de-0c-1000"
},
"19:38:51:311": {
    "e": "changed",
    "id": "18",
    "r": "sensors",
    "state": {
        "buttonevent": 7002,
        "lastupdated": "2024-05-13T17:38:51.226"
    },
    "t": "event",
    "uniqueid": "d8:5d:ef:11:a1:00:45:de-0d-1000"
},
"19:38:52:948": {
    "e": "changed",
    "id": "18",
    "r": "sensors",
    "state": {
        "buttonevent": 8002,
        "lastupdated": "2024-05-13T17:38:52.917"
    },
    "t": "event",
    "uniqueid": "d8:5d:ef:11:a1:00:45:de-0d-1000"
},

BR Helmut

Yes. Did not work.

I indeed fixed it only for the RM01 model. Will add the RB01 also. I hope this will go online with the new deCONZ beta release today.

Are there any other modelids for this switch I have to consider? Don’t have any more to test.

This is a very specialised fix only applied to this switch and model because they handle the uniqeid differently then other switches.

I looked also into the log that duffy posted, and with the model RM01 it should already work in deCONZ 2.26.3.
I see the buttonevents and the uniqueid should result in the correct switch editor rules like they do for Andreas.

Im not sure why it is not working for duffy yet.
I’ll check it witch ConBee III

Thanks, I have two different model ids RM01 (4 buttons) and RB01 (4 buttons and 8 buttons).
I checked the Busch Jäger Doku, it seems there are the only models. They have 2,4, and 8 buttons for each of the models.

I will try switching to the beta to test it.

Attached the pages of the models / variants.


Link:

Hi @ChrisHae - thanks for your detailed feedback.
I am using the model with the SKU “07” referring to the document, @Andreas has posted in the article next to yours.

Every some minutes I am receiving (without pushing any button) following events:
“17:52:16:15”: {
“attr”: {
“id”: “15”,
“lastannounced”: “2024-02-16T05:17:49Z”,
“lastseen”: “2024-05-14T15:52Z”,
“manufacturername”: “Busch-Jaeger”,
“mode”: 1,
“modelid”: “RM01”,
“name”: “Wohnzimmer Hauptschalter”,
“swversion”: null,
“type”: “ZHASwitch”,
“uniqueid”: “d8:5d:ef:11:a1:00:45:de-0a-1000”
},
“e”: “changed”,
“id”: “15”,
“r”: “sensors”,
“t”: “event”,
“uniqueid”: “d8:5d:ef:11:a1:00:45:de-0a-1000”
},
“17:52:16:18”: {
“attr”: {
“id”: “17”,
“lastannounced”: “2024-02-16T05:17:49Z”,
“lastseen”: “2024-05-14T15:52Z”,
“manufacturername”: “Busch-Jaeger”,
“mode”: 1,
“modelid”: “RM01”,
“name”: “Wohnzimmer Hauptschalter”,
“swversion”: null,
“type”: “ZHASwitch”,
“uniqueid”: “d8:5d:ef:11:a1:00:45:de-0c-1000”
},
“e”: “changed”,
“id”: “17”,
“r”: “sensors”,
“t”: “event”,
“uniqueid”: “d8:5d:ef:11:a1:00:45:de-0c-1000”
},
“17:52:16:20”: {
“attr”: {
“id”: “16”,
“lastannounced”: “2024-02-16T05:17:49Z”,
“lastseen”: “2024-05-14T15:52Z”,
“manufacturername”: “Busch-Jaeger”,
“mode”: 1,
“modelid”: “RM01”,
“name”: “Wohnzimmer Hauptschalter”,
“swversion”: null,
“type”: “ZHASwitch”,
“uniqueid”: “d8:5d:ef:11:a1:00:45:de-0b-1000”
},
“e”: “changed”,
“id”: “16”,
“r”: “sensors”,
“t”: “event”,
“uniqueid”: “d8:5d:ef:11:a1:00:45:de-0b-1000”
},
“17:52:16:22”: {
“attr”: {
“id”: “18”,
“lastannounced”: “2024-02-16T05:17:49Z”,
“lastseen”: “2024-05-14T15:52Z”,
“manufacturername”: “Busch-Jaeger”,
“mode”: 1,
“modelid”: “RM01”,
“name”: “Wohnzimmer Hauptschalter”,
“swversion”: null,
“type”: “ZHASwitch”,
“uniqueid”: “d8:5d:ef:11:a1:00:45:de-0d-1000”
},
“e”: “changed”,
“id”: “18”,
“r”: “sensors”,
“t”: “event”,
“uniqueid”: “d8:5d:ef:11:a1:00:45:de-0d-1000”
}

Wondering if they have to re-paired as their pairing was in February? This evening I will ask my brother-in-law to capture the event for this 4-button-switch and I will compare with him.

BR Helmut

Maybe to add the config I have tested (one example):
there are two devices combined to group “Unterhaltung”:
{
“action”: {
“alert”: “none”,
“bri”: 127,
“colormode”: “hs”,
“ct”: 0,
“effect”: “none”,
“hue”: 0,
“on”: false,
“sat”: 127,
“scene”: null,
“xy”: [
0,
0
]
},
“devicemembership”: ,
“etag”: “91fe062f4cb0327896c2bc3ad4316cbf”,
“hidden”: false,
“id”: “5”,
“lights”: [
“19”,
“18”
],
“lightsequence”: ,
“multideviceids”: ,
“name”: “Unterhaltung”,
“scenes”: ,
“state”: {
“all_on”: false,
“any_on”: false
},
“type”: “LightGroup”
}

And with the rules I have found the “on” (key 6):
{
“actions”: [
{
“address”: “/groups/5/action”,
“body”: {
“on”: true
},
“method”: “PUT”
}
],
“conditions”: [
{
“address”: “/sensors/d8:5d:ef:11:a1:00:45:de-0a-1000/state/buttonevent”,
“operator”: “eq”,
“value”: “6002”
},
{
“address”: “/sensors/d8:5d:ef:11:a1:00:45:de-0a-1000/state/lastupdated”,
“operator”: “dx”
}
],
“created”: “2024-01-01T16:22:20”,
“etag”: “d83626b833c85786f5176a484625ba8b”,
“lasttriggered”: “none”,
“name”: “Rule ON”,
“owner”: “99AC774952”,
“periodic”: 0,
“status”: “enabled”,
“timestriggered”: 0
}

And the “off” on key 5:
{
“actions”: [
{
“address”: “/groups/5/action”,
“body”: {
“on”: false
},
“method”: “PUT”
}
],
“conditions”: [
{
“address”: “/sensors/d8:5d:ef:11:a1:00:45:de-0c-1000/state/buttonevent”,
“operator”: “eq”,
“value”: “5002”
},
{
“address”: “/sensors/d8:5d:ef:11:a1:00:45:de-0c-1000/state/lastupdated”,
“operator”: “dx”
}
],
“created”: “2024-05-12T14:27:08”,
“etag”: “91fe062f4cb0327896c2bc3ad4316cbf”,
“lasttriggered”: “2024-05-14T15:50:05”,
“name”: “Rule OFF”,
“owner”: “8D5C7A81FF”,
“periodic”: 0,
“status”: “enabled”,
“timestriggered”: 3
}

So I see the rules has been captured as triggered correctly but the action somehow on the group does not happen.

Maybe this helps to narrow down the problem?

BR Helmut

I have asked my brother-in-law to do same exercise and I have compared the JSONs with mine - absolutely identical besides that he has another ids, guid and names. He reported, after upgrade to 2.26.3 he has removed the switches and re-paired again - just wondering what this could help?
Thanks for your feedbacks in advance
Helmut

deCONZ 2.27.0 beta is out now and has the fix for the model RB01 included.
duffy, you have the switch with the model RM01 so this should also work already.
It is needed to delete all buttons in the switch editor and create new ones.

I think re-pairing the switch is not needed.

@ChrisHae
I have installed the 2.27.0 beta and I can confirm that the RB01 models are now working like the RM01 models. Re-pairing is not needed.

Hi @ChrisHae - thanks for the procedure to remove the switch from the group and re-add them. This worked for me - even on 2.26.3
I am now able to go ahead with my config and add room by room while removing it from Hue Bridge :slight_smile:
BR Helmut

@ChrisHae
I tried to find out and to understand which changes are made that the RB01 models are now working for all rows.

But I didn’t find anything in the documented changes at github.

It is not a change in deCONZ. just a change in the Phoscon App that is shipped with the new release of deCONZ. The error was that the switch editor of the Phoscon App added a wrong id to the Rest API rules that it created. The ids of the Bush Jaeger switches are slightly different than other switches because they add extra numbers to it depending what button is pressed.

P.S. the change is not yet in the Android or iOS Version of the Phoscon App but will be in the next update.

Phoscon doesn’t release change logs

Thanks for the explanation.