Bug? Sensors disappear after deCONZ restart

Hello. Everything works perfectly with my ConBee II and Xiaomi Sensors, but every time I restart deCONZ (gently with File>QUIT, or brutally killing application, or restarting raspberry) one or more sensors disappear. They are visible in the web app, but they don’t update their state. Watching the log I noticed that they are stored in the deCONZ DB.
I’ve tried to follow the workaround I’ve found here: #2273.
I’ve also tried resetting sensor twice immediately, but with no luck (after this operation, I noticed that it disappeared from the log the warning “Missing cluster in sensor fingerprint”).

When I reset missing sensors, their state returns online and they continue to work without troubles.
I’ve tried running deCONZ in all the alternative ways: as a service, directly with the sh, platform minimal, with the GUI…

I’ve shared a log where you can find only one sensor survived and its name is “Studio”. All the sensors have new batteries and are quite close (in the range of 4-5 meters) to ConBee and with no obstacles.

I tried a lot before opening this bug and I noticed that the problem affects a larger number of sensors, proportionally to the running time of deCONZ. If I start deCONZ, I reset sensors and then I immediately restart deCONZ, more o less all the sensors survive, but if I restart deCONZ after a few days, every sensor disappear. I don’t know if it’s only my suggestion…

Here is the environment info:

  • Host system: Raspbery
  • Running method: Raspbian
  • Firmware version: 26660700
  • deCONZ version: (2.11.5)
  • Device: ConBee II
  • Do you use an USB extension cable: yes
  • Is there any other USB or serial devices connected to the host system? no

Here is the log: https://github.com/dresden-elektronik/deconz-rest-plugin/files/6907805/debug.txt

This problem is extremely ennoying and I appreciate any help.
Can I help you with more information?

Thank you very much!



Did you try this

1 Like

Oh thank you! I’m trying now and yes, descriptors are incomplete. After the procedure you suggested, those descriptors are complete.
I’ll let you know the outcome of this action in few days, in order to test deCONZ for a while.

Thanks a lot for the fast response.

1 Like

Hi all! After few days I can say that the problem is solved. I’m very happy right now, because I can continue with my project!

Thank you!



I have been in contact with Dresden Electronik support for the last month to resolve this without succes… This post resolved my problem as well!

Thank you so much!


I have same problem with Xiaomi temp sensors (WSDCGQ11LM). Some of them reconnects after some minutes, some of them not.


Business temp sensor is highlighted, which reconnected after 10 minutes (I think it is ok because there is no big temp change) .

…but I have another temp sensor named Bathroom and this does not reconnect automatically until I press button on it. I am waiting now hours to reconnect, I tested with big temp change (showering), but nothing.

It is not clear to me, what should I see in node info? Power descriptor should be filled in all case? That’s n/a for all my devices (even those that work well).

Some info:

Ikea Symfonisk volume controller (reconnect: ok):

Ikea Range extender:

Bathroom temp sensor:


Grayed device mean they are generaly disconnected.
Its normal you have a disconnected router ?
Can be connection issues, you can take a look in logs to search error like thoses one Zigbee Error Codes in the Log · dresden-elektronik/deconz-rest-plugin Wiki · GitHub

For me your device look connected.

Remember never move Xiaomi/Aqara device after the pairing.

Power descriptor should be filled in all case?

No can take 1 hout before the battery icon appear for exemple.

Woke up this morning to this. It happens about once a month. I’ve started replacing things with Tuya protocol instead as this is so annoying. All in gray are un-paired. Try to restart Deconz - nothing changed. I now have to manually go all around again.
My 2 range extenders from Ikea also felt down.

Following up here as things got resolved.

The Ikea Range extenders seems to cause more problems then value. I removed them
I added just a couple of Phillips Hue lights in my network instead
I re-paired everything. Lights, sensors, switches. (157 devices…)
Starting with the lights, then switches, then sensors. (Since I was unpairing/re-pairing)

The cuplprit. In my office, I have ikea panel and lights linked to an analog switch. My partner liked to turn it off with the switch - which destabilized the network across the whole house. So I installed a zigbee swith beside instead.

I also found a zigbee light that was part of a series turned off by a zigbee switch. Removed that light and replace with non smart light instead.

In other words - avoid at all cost turning off electricity on zigbee devices. 5 days so far - nothing failed.

lol, so was just Xiaomi/Aqara sensor that loose their parent ?

You should also have deCONZ up to date (2.14.1) and the firmware (26720700).

If you use the ConBee II you should use a USB extension.

Repairing is not needed in the most cases.

No, it was anything and at random. There’s a single ikea sensor that stood out as the evil one, always failing even with fresh batteries… but it started slowly and got worse and worse… making me miserable :slight_smile:

This is already my setup for years (the cable) and i regularly update