Bug? Network not working correctly after restore from backup

Hi Folks,

For the past few days I have been unsuccessful in trying to migrate my existing setup (Pi3B+/Raspbee) to new hardware (Pi4/Conbee II). After some research I found some posts indicating that it should work like this:

  1. Backup all data on the old hardware using the Phoscon app
  2. Setup the new device according to the docs
  3. Restore from the backup performed in step 1
  4. Be happy

Unfortunately step 4 is not working properly :slight_smile:

Once the backup is restored, I can see my network properly in Deconz but most of my devices won’t react to commands anymore. I have a few Busch Jaeger wall switches and controls as well as a Osram Lightify LED strip and some Osram Smart+ plugs. The only thing working after the restore is the LED strip. None of the plugs and none of the Busch Jaeger devices work anymore (won’t switch and won’t return any attribute information when reading the “Basic” cluster in Deconz). What I also noticed is that in Deconz my network somehow looks “thinned out”. Whereas before there were a lot of connections between all of my devices, after the restore there were only very few.

Here is what I tried already, without success:

  • Ensured that the network settings are exactly the same before the backup and after the restore
  • Ensured that all components have the latest software and firmware versions installed (Deconz/Raspbee/Conbee II)
  • Moved the Pi4 with the Conbee II stick closer to my switches in case there is a problem with radio reception

At this point I am stuck and need some pointers:

  • Should I be doing anything differently?
  • What can I do to debug this problem?

I am reluctant to reset my network and integrate everything from scratch since the Busch Jaeger switches are a real PITA to set up. On the other hand I really want to switch away from the old Pi3…

Any help would be highly appreciated!

Cheers, Uli

It probably takes some time after the backup was loaded until all devices are fully functional. Are more devices reachable now ?

I can’t tell because after waiting for maybe 30 minutes I switched back to the old setup.

Fun fact: I just turned off the old Pi3, pulled out the Raspbee board, plugged in the Conbee II, booted again and everything continued working. So it seems I am running into some trouble with restoring the backup. Apparently that step is breaking my network. Any advice on how to debug this?

So if I understand you correctly, you created a backup of your system with the old raspbee and then you connected the ConBee2 and loaded your backup. Then it didn’t work at first and you switched back to Raspbee. And now you plugged in your ConBee2 again and your network is working?

The ConBee2 still has the same network settings as the RaspBee from the initial backup import so the network should work. So what is the problem now? Do still have to restore your groups, scenes, etc. but don’t want to load the backup again because it could break someting?

Not quite. Like I said, I want to move from Pi3+Raspbee to Pi4+Conbee2. For that I tried the backup/restore route as described in my first post - that didn’t work. What succeeded now was pulling the Raspbee out of the Pi3 and plugging in the Conbee2 (into the Pi3). So no backup/restore involved - and I still am on the Pi3 not the Pi4. So I basically just ruled out a problem with the Conbee2 which leads me to believe that there is a problem with the backup/restore or the combination with backup on Pi3 and restore in Pi4.

When everything works with the Conbee2 on RPI3 then it should also work with ConBee2 on RPI4. There are 2 main things that cat imported during a backup. The network settings of the ConBee2 that now should be the same as the ones of the RaspBee and the deCONZ database that include all groups, rules, scenes, etc…

So you could try to import the backup file on the RPI4 again or just copy the deCONZ database to the RPI4 ( ~/.local/share/dresden-elektronik/deCONZ/zll.db)
This file is (should be) included in the backup file.

Don’t forget that when using an SSD, you can encounter Interference issues.

1 Like

Copying zll.db instead of backup/restore through the Phoscon app did the trick. I am now on the Pi4 with Conbee II.

This was the key tip. It runs with a USB extension :sweat_smile: :ok_hand: :clap: :muscle: