Binding with Amazon Alexa fails

Hey there,

in the phoscon app there is the possibility to pair with Alexa. Unfortunately this does not work for me. I press the button, and let Alexa search - no luck. I read somewhere that you have to start on Port 80 to sometimes make it work. I am no Linux expert (running it on a raspberry pi 4), but I figured out you can hand over a paramter like -http_port 80 or something, but the weird thing is when I tried this via the GUI with run, it still started via port 8080, when I did it via the console it started for whatever reason on port 8090 instead of 80. I am not even sure if this is the solution, but I got stuck. Someone has an idea?

Can you start it with sudo?

But you are only running one version of deconz?
Has been my problem for some time…
I was running the headless and the gui-version at the same time. Only thing not working was the pairing with Alexa.

How can I tell if I am running both versions at the same time? I was not aware there are two versions. I think I’d rather prefer to have always the headless running (how do I autostart it?) and start the gui-version only on demand.

I was able to start the application with sudo, but afterwards the user interfaces still ran on port 8080, but all devices and settings were gone, it was like a fresh install. Still not able to connect to Alexa. After starting it regularly again, I was back to were I was before, all setup up not able to connect to Alexa.

Any ideas?
Anyone knows how I can check if GUI and headless version are running?


Hi sorry, I was on vacation and mails where redirected to Spam :see_no_evil:

To see if both version are running, just type:

sudo systemctl status deconz
sudo systemctl status deconz-gui

But if you use the headless version, than it’s easy to see if the gui version is running, because you should see it on you desktop :wink: