Behaviour of configuration surviving reboot

I am a software engineer - however brand new to deCONZ/Phoscon.

I set up my Zigbee network with several lights, then backed up the configuration through the Phoscon App interface.
I then rebooted the raspberry pi, and when it came back up, all of the lights were gone from the Phoscon interface. I waited several minutes and they did not reappear.
I reloaded the configuration, and one light showed up in the interface, but its name was reset back to the default “dimmable light”. Also, my groups had their names reset back to something default.

I have reflashed the SD card, and repeated this a couple of times, and always get similar variations of the same odd behavior.

This is my setup:

  • brand new Raspbee II
  • new-ish Raspberry Pi 4
  • official Pi 4 Power Supply
  • no other peripherals connected, other than an ethernet cable to my switch
  • “Rasbian Buster Desktop” SD image downloaded from here: RaspBee SD-card images

I guess the first thing I would like to clear up is:
What should I expect the Phoscon App behavior to be?
What I was expecting, is that all configurations would persist across reboot, including names, etc - whether or not the light was reachable anymore.

What it feels like however, is that the Phoscon app is not just displaying configuration as is persisted on disk, its somehow merging it with whether or not the device is immediately reachable, and that determines if the device will appear in the interface.

Can someone describe how this should be behaving, and perhaps some suggestions of why I’m getting such consistently flaky behavior from the software?

Moved to Phoscon app > General support

You have changed nothing on the image ? It s look like a right permission issue …

Hi @Smanar - correct I’ve changed nothing, and run multiple times (fresh images).

Despite my love of tinkering :slight_smile: I refrain from doing anything beyond what I believed is the standard setup.
Install, boot, follow wizards.

Can you try first to update deconz and the firwmare, I don’t know what is the defaut one, and it was some corrective.

After that, can you try the backup feature in phoscon, it use the datafile too, so if you have some right issue, you probably will have error here too.

If you can share logs at startup too ? with “info” “info_l2” “error” and “error _l2” ?

Hi, can you explain how to obtain the startup logs?

You can use command line deCONZ debug flags · dresden-elektronik/deconz-rest-plugin Wiki · GitHub

But to test the backup feature, you can do it after the startup, logs are available in deconz / help / debug view (and can be enought to see issue, easier than command line)

I’ve tracked down repro steps.
I’m pretty sure this is a case of not sanitising inputs.

  1. Through Phoscon app, add a new device (I’ve only tried with lights)
  2. When the light appears, edit it
  3. Give it a name containing a single quotation (i.e John’s Bedroom Light)
  4. Using VNC, close deConz
  5. Relaunch deConz and wait for it to settle

Expected Results:
All lights should show up in deconz, as previously configured

Actual Results:
All nodes do appear in deconz, however the ones that were configured with a single quote in their name, appear with rubbish as their name, and when viewing the Phoscon app, those garbled lights do not show up in Devices/Lights.

Note: Devices containing a single quote in their name will also fail to be either saved or restored from backups.

You have updated your deconz version ?

Because I m trying on my side

  • select a light
  • rename it “John’s Bedroom Light”
  • restart deconz

And I haven’t issue.

Hi @Smanar

Thanks for trying.
I have not upgraded since my last post (as I had just gotten used to my version’s idiosyncrasies, and didn’t want to have to re-learn how to “whisper” deconz…)

Please note, however, that the test you have described is not quite my issue.
I used your steps and also did not have “the” issue - but after rebooting deconz, my new name with the single quote had reverted back to the original.

So, for example, if your light was “Johns Bedroom Light” and you changed it to “John’s Bedroom Light” it would revert back to “Johns Bedroom Light” after reboot.

My scenario was to use a single quote in the name when originally creating the light.

If I am to upgrade my version - what’s the best way to do that? I started from the raspberry pi image on the website, so of course I can grab the new one and blow away my SD card… is it safe to apt-get --only-upgrade? Save me from having to set up my passwords and network all over again…

Hi again @Smanar,

Please note: I’ve upgraded my deconz to 2.12.06 and I still see the same behavior (when using the steps you described, a rename… it reverts to the name without the single-quote).
I have not re-tested deleting and re-adding - as given the failure I just described, I can only assume exactly the same result.

So you have the issue without the reboot now ?
Haven’t tried with reboot on my side yet, but it s strange, why it s the reboot that have an impact and not the close/relaunch ?