Aqara WXKG07LM - two switches connect but refuse to enter network

Hi All,

I have 8 Aqara WXKG07LM 2-Gang switches of which 6 are working without problems for at least a few months. Two switches however refuse to become part of the network although they are found by Phoscon/DeCONZ and are visible in the DeCONZ app:

I have removed the switch called “Schakelaar Keuken” and re-added it to no avail. I had a spare switch lying around ("Schakelaar Keuken 2) that I tried to add but that one also does not want to connect to the network. Note that both switches are in the vicinity of a router so it is unlikely to be an issue with reception.

Any tips?

How many routers do you have?

About thirty I think. I have made a screenshot from deCONZ showing you the routers nearest to the location of the switch. Note that in the mean time the second switch has found a connection (after a day or so) -but I can’t get it to communicate.

did you try this link already?

1 Like

Hello, but what are you calling “refuse to become part of the network”
They disconnect after a time ? they are not visible in the API ? or just not working ? (The green line can be missing)

the second switch has found a connection (after a day or so) -but I can’t get it to communicate

It s the disabled one on bottom ? “keuken” ? So yes for me this one have disconnected, Aqara/Xiaomi can disconnected if they have problem after somes hours.

If you have checked if the device is perfectly included using the @Mimiix link, Have you tried to make the inclusion at other place ? Aqara/Xiaomi are not compatible with all routers.

Have you tried the “source routing” Never used on my side it seem it can help again disconnection on big network, but not the same problem than you, for you it s more a connection issue.

I will try this tomorrow. I need a second pair of hands to go through the settings :slight_smile:

Hi Smanar,

The switches refused to get connected in deCONZ. But that seems to be cured now.

De switch “Schakelaar Keuken 2” now looks like it is operating as expected. I have a dzVents script that controls the roller shutter based on the switch and that is working now as well.

So it seems like I am too impatient when it comes to Xiaomi devices :expressionless:

Note that the switch “Schakelaar Keuken” (the original switch) still refuses to function. But since I had one spare, I decided to write off that switch.

You say that Xiaomi devices are not compatible with all routers. Is there more info on that somewhere? The router closed to the switch is a _TX3000_vd43bbfq. Is that on the incompatibility list?

Looking forward to your reply!

Yes this link for exemple Xiaomi & Aqara Devices - Pairing & Keeping them connected - Devices - Hubitat

On my side I can confirm incompatiblity with Legrand (not tested the new generation) and some Osram devices.

Haven’t see problem Xiaomi<>Tuya (the _TX3000_vd43bbfq)

1 Like