Aqara Smart Wireless Switch WXKG11LM does not pair


I am trying to pair an Aquara mini switch WXKG11LM with my ConBee II using Phoscon (ver 2.13.04 12/18/2021, Firmware 26660700) attached to a RPI3B+ running home asssitant 2021.12.8 but not successful.

I am able to pair and use Aqara temperature/door/water/motion sensors without any issue but not the mini switch.

I tried to pair it as a sensor, a switch and even a light without success.

Any thoughts?

Please check the git, there’s an open issue on this.

Are you referring to this git page for the open issue: Pairing Aqara Smart Wireless Switch WXKG11LM · Issue #917 · dresden-elektronik/deconz-rest-plugin · GitHub
Given it’s status is closed, is it being addressed?

@Mimiix , is it normanl that I only see the battery level and the temperature reading once the switch is paired with Home Assistant?

How do I get the state of the swtich?

You need to listen for the events in the event listener.

The issue is still present in version 2.15.03.

This issue was closed on the Git page quoted by Mimiix (Pairing Aqara Smart Wireless Switch WXKG11LM not working anymore with version 2.13.X · Issue #5599 · dresden-elektronik/deconz-rest-plugin · GitHub), but indeed is it still present in versions after 2.12.

Is there any solution planned besides the workaround suggested in that thread (reverting temporarily to an older version) ?

I’m getting the same issue with the WXKG11LM using deConz as well. Home Assistant picks up the Temperature Sensor and Battery Sensor but not the switch.

Does it show events in the event listener?

1 Like

You don’t get an entity for remote control button actions. Only events and device triggers

1 Like

Thanks for the suggestion, I’ve never used triggers before with Node Red. I tried the device trigger node and it works fine. Thanks!

1 Like