Aqara Presence Sensor FP1 Unreachable every few minutes

Hey guys.

I was lucky to get two Aqara Presence Sensor FP1 from aliexpress.
One is placed near the conbee II and is working without any issue better.
The second one is far away from conbee II and has dozends of routers (mostly hue bulbs) in between.

Sadly, both are marked as “unreachable” sometimes, the second one every few minutes (~5 mins).

I have tried the following to solve the issue:

  • filtered unavailable state in HomeAssistant as a workaround (my feelings are that when the state of the sensor changes it trys to send the new state and succeeds, so last state which deconz has, is the correct one)

  • unplug a few non hue routers near the sensor → same issue occured

  • move the sensor a meter from the last position → same issue occured, sadly cant move much because of the power cord

  • used DDF of v2.17.0 beta and hot reloaded it (currently using deconz addon of HA which is at v2.16.1) → same issue occured

PS.: around the FP1 are ~6x aqara door/window sensors, a hue motion sensor … and so on … they are working since years without any issue!

Can anyone please help me to debug the issue?

Thank you

Here are 2,5 hours from within home assistant.
Deconz is reporting both sensors unavailable very often.

raw data:

filtered (ignored unavailable as workaround):

Color gray is unavailable.

Any hints?

Does the device what it is supposed to do or is functionality impacted?

After filtering the unavailable/unreachable state, it’s doing what it should. So i think the unreachable/unavailable state should be handled differently.

When you enter/leave a room in an unreachable state, it’s getting reachable immediately and the correct presence state is received by deconz.

Do you have this device?
How does it behave on your side?

Yes, I have the device. Have a full blown debug file from 2 days ago over 4 hours. It never went unreachable. Might be due to the fact that it’s in my small test network.

Tbh, even if it would, I couldn’t care less as I do not pay any attention to the reachable parameter. lastseen is where the music plays.

Would be cool if you could test it in your production network.
In my case i have ~155 nodes where a lot of them are hue routers (bulbs).

Yeah, now i also dont care on the reachable parameter.
With my workaround in HA i ignore it, here is my sensors.yaml:

- platform: template
      friendly_name: "Presence Detector Bad Filtered"
      value_template: >
        {% if states('binary_sensor.presence_detector_bad') in ['unavailable', 'unknown', 'none'] %}
          {{ states('sensor.presence_detector_bad_filtered') }}
        {% else %}
          {{ states('binary_sensor.presence_detector_bad') }}
        {% endif %}

But at first i ran into the issue, because HA is using reachable and switches the binary_sensor to unavailable. When you merge multiple sensors into a group, unavailable means “off”.
In my case i had grouped an hue PIR sensor and the FP1.
My son was in an dark bathrom, when the FP1 get’s “unreachable” :rofl:

As stated above: after filtering the unreachable/unavailable in HA, the sensor is working as it should.

So my question is:
How is “unreachable” state evaluated and maybe can it be improved on that sensor?
I think my zigbee mesh is good enougth, because other nodes working as they should.


Just hooked it into my prod and assigned a push notification to know about it going unreachable. Let’s wait and see.

Thanks a lot!
Hope you can reproduce the issue i am facing…

@Swoop Any news from your side?

Well, it’s just there all the time :man_shrugging:

1 Like

I had a similar issue a couple of months ago, also with a Aqara sensor. A simple relearn did the job at least for me.

1 Like

@Swoop @Gautama
thx for testing and your hints.

Without changing anything (no relearn, no restart of deconz…) one sensor (Presence Detector Bad) is now working (See diagram over the last ~14 hours).

Sadly the second (Presence Detector WZ) one has that issue.

I will relearn it and see how it goes.
Also, i will leave my “filtering” HA workaround in place.

thx pOpY

It seems that relearn has solved the issue for the FP1 “Presence Detector WZ”.

Thanks again for the hint.

1 Like