Aqara motion sensor p1, api settings dont saved?


i set the reation time over the api with postman to 10 seconds, but he doesnt save it, when i restart my Homeassistant its back to default.

gives a way to save the over api set values?

I’m pretty sure the actual way of setting values does indeed work correct, but not the reporting of the set value. What you might try is setting a rather large value via API and confirm by testing if that was kept. There’s also the possibility to doublecheck attribute 0x0102 (iirc) of cluter 0xfcc0 if the values sticks or not.

Getting my own in 1-2 days to correct the current value reporting…

I cannot confirm any issues with the device. Setting a value via API works and the value is persistent.

after a reboot of HA ?


here when i change the duration (10 sec) over the api it works in HA but after a restart its set back to 30 seconds.

i played now a little bit more, the value is saves here 10 seconds

        "success": {
            "/sensors/70/config/duration": 10

than i checked in HA if the sensor works with 10 seconds, the first time it worked, the state changed, but then he doesnt seen motion, the sensor is in sleep than for 30 seconds, i must wait the 30 seconds until i the sensor registers motion again.

that the exact time that is set by default 30 seconds

thats a problem, because the sonsor doesnt work with a other value than 30 seconds. or work only one time


do you use HA ?
i updated my post above

The Problem is thill there !

who of the admins or develops can help?

the device duration resets every time, the API command is not persistant
or the report back time is not working with HA, can now please someone say something about this or help?7

its 8 days without any help or any ideas??

what must i do to get help???

Swoop wasn’t able to reproduce it in his Setup. Than something else might be wrong with your environment, perhaps access issues on the database or something else with the storage. I am not sure what you are after, but nobody is obligated to help out.

@de_employees, perhaps you have any ideas?

okay maybe I’m wrong but isn’t this the official deconz forum? for the product i paid money for (conbee2)?

and I’ve waited 8 days, but nothing comes up, and just because a user says it works for him doesn’t mean it works. there are several posts in the homeassistant forum on exactly this problem, even there without a solution.

and I strongly doubt that it is due to my setup, but of course I can’t say 100% because nobody is interested in the problem.

I was more than patient and I find it really quite weak to give such support for a product.

and to put my post in the other THREAD on hidden, although this only reflects the current status in this forum, I also find it quite interesting.

To be blunt: The Conbee2 is fine, right? You purchased it, it works. There is no “support” included in the purchase. Any support afterwards is complimentary.

This “User” is one of the devs with the most knowledge of deCONZ. He has actually implemented this device in deCONZ. Also, be adviced it’s holiday season.

Because it was off-topic and not contributing at all.

Either way, behind the scenes i pinged @Swoop , he’ll check in tonight.

It’s not unwillingness, otherwise I, or anyone else, wouldn’t respond now. DE is just shortstaffed and loads of stuff can go wrong with Zigbee. Especially with brands like Xiaomi which won’t stick to the standard.

1 Like

I’m afraid this is not a matter of deCONZ support, as it is running perfectly fine. Please also note that quite a number of people seem to share your experience which is not deCONZ exclusive, but happens frequently with z2m, zha and others.

I’ve checked the code once again and what’s transferred via zigbee since I wasn’t too sure if I verified the value which is being used to get the current setting from is really adequate, but it is. Having reread the posts now perfectly makes sense, also, that it works only once, as you set a lower value.

Now why doesn’t it work?
The answer is pretty simple: you haven’t waken up the device by pressing the button on the back :slight_smile: And just to be clear, this is specific to the device and mandatory as that press enables it to receive anything

hey swoop

of course i pressed the button before, i know that i must wake up the device before make changes on the API or the sensor itself.

even if I didn’t read that in the wiki manual? or did I miss it?
maybe you should write something about it that’s not exactly unimportant

but when everything is working by all its okay, i reaktivated the original bridge, and there the sensor works well and everything can be changed included the duration.

it is the same as back then with the ikea rollo where everything should be fine with everyone. But there were still more like a few entries in forums etc. but still thank you very much


the conbee2 advertises with the support of exactly these devices and this influences the purchase decision. And you buy not only a conbee2 but also the promise that diverese devices and manufacturers are supported. otherwise it would hardly be advertised.

“User” is not an insult or contempt, but my level of knowledge at the time so maybe come down

off topic ? 12 days have passed and the thread creator did not have an answer, only because of my answer something happened.

but it’s okay, I’ve now had to find out for the second time how it works here in the forum and that’s okay. I’m out, delete my account otherwise I’ll do it myself, asking for official help here is futile effort. But also thank you for your help so far

and as soon as there is the possibility I switch from the conbee to an alternative. you may not care here, but that’s for sure

I have the feeling that you take this way more personal then you should. Everyone responding here is not employed by Dresden. Nobody of @de_employees checked in to help you.

Either way your welcome :slight_smile:

1 Like

The green grass on the other side of the mountain… I have about 200 Zigbee devices with a Conbee 2 with Ikea, LIDL, Osram, Heimann, Aqara, Tuya and the conbee 2 software got lots of improvements and support for new devices since 2020 when I have started the Smart Home journey.
I have nothing but respect for this community, the Conbee 2 creators and all the contributors to all related projects, you all brought me a lot of joy !
Love you all guys!


@pimp1310 Remarkable, I seem to now be able to reproduce this :thinking: It appears to be timing related, which is kind of nasty. Can you please try to change the value via API and immediately press the button? When I wait more than 4-5 secs, I cannot see any write command being send in the sniffer.

i will test it and give than feedback.


as you can see, there is apparently something wrong with the sensor, maybe next time don’t treat people so condescendingly and just dismiss everything

It is not for nothing that I take the trouble to write a thread here, before that I spent hours looking for a solution.

but well I don’t care now, I think it’s pointless to continue to deal with you on this topic

I am not dismissing anything, just looking at the facts I asked a dev to have a look. He said initially it worked fine and now after all it doesn’t. What do we have to go on? I am sorry If you have the impression it’s all pointless.

The only thing that bothers me, is the way you demand answers from people that they can’t simply provide. The demanding manner is not showing respect nor making a path to have a constructive solution in which we can see where it goes wrong.

I’m happy there’s a issue here and that we can actually fix it :)!

@Swoop is this also related to the FP1? I currently don’t the the P1 for testing (still on the order list), but can make tests with the FP1 if that helps.

This would generally affect only deep sleepers (FP1 is receiver on when idle). They’re just able to receive for like 3-4 secs, so no real surprise, and you need to know exactly under which conditions it mac polls.

Maybe it’s somehow possible to speed up the state change a little bit, or we introduce an additional verify state… Anyway, the solution is to at least push the button once wihtin an interval of 2-3 secs a few times. That succeeded 100%.

Ah ok understand, I think if the P1 does the special Xiaomi report once per hour, and this message is marked with the “awake” keyword, the StateChange should kick in if the SC timeout value is configured long enough.

Knowing when the sensor is actually MAC polling can unfortunately only be seen in the sniffer.

okay i tested it, and it works until now, I will test it more intensively in the next few days

thank you