All lights have disappeared!

I’ve had my setup for several years with very few problems.
Tradfri lights
Hue and tradfri remotes
Aqara motion sensors

Conbee is running in a dedicated Raspberry Pi and control is through Home Assistant and Node Red.

Overnight, all my lights have disappeared out of the Phoscon App. The remotes, switches and sensors are there but the lights are gone. They’re not even listed as offline, they’ve completely vanished and I just have a “No lights were connected yet” header on the lights page.

I’ve tried changing the Zigbee channel, no difference. One weird thing is that the channel shows as 0 no matter what I set it to.

The version is 2.05.64 / 22/04/2019 and shows as up to date (although I’m not sure that’s true).

Can anyone help me get my lights back? I’ve not tried relearning any of them yet, I really don’t want to do that with 30 plus bulbs!



You are on a very old version. @de_employees, another case of users not understanding the version layout.

You need to update the deconz software, the date is the firmware.

Can you share a screenshot of deconz gui?

Screenshot attached.
There are no firmware updates showing. I assume there’s a way to force an update?


That’s phoscon, not deCONZ.

Additionally, deconz needs to be updated in the same way all Linux packages are updating.

I recommend reading this deCONZ for Dummies · dresden-elektronik/deconz-rest-plugin Wiki · GitHub

Well, seems the fix was straightforward enough. Plug the USB extension back in to the Pi. It had pulled out. :man_facepalming: :

I checked it after trying to connect via the deconz gui and it not being able to find the stick. In my defence, the pi lives under the stairs and hasn’t been touched/moved for 3 years or so.

Just running updates now. Looks like I have to move over to Buster too.

Updated deconz to the latest stable but it won’t start.

deconz.service - deCONZ: ZigBee gateway – REST API
Loaded: loaded (/lib/systemd/system/deconz.service; disabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Sun 2023-04-30 10:17:15 UTC; 2s ago
Process: 978 ExecStart=/usr/bin/deCONZ -platform minimal --http-port=80 (code=exited, status=127)
Main PID: 978 (code=exited, status=127)

Apr 30 10:17:15 phoscon systemd[1]: deconz.service: Failed with result ‘exit-code’.

Tried updating repositories and running all updates but it now won’t boot so I’m trying to fix that before I can get back to deconz

Ok, life’s too short for that nonsense.

Restored the zll.db file from the original install to a new one, all up and running again.

Now on v2.19.01 / 19/09/2022 and firmware26780700

Thanks for the quick responses and pointers @mimilix. Very much appreciated.


1 Like