After Zshark installation - no connection to deconz app

Hi,

my Silvercrest door and window contact sensor (Lidl) cannot be added with the Phoscon App or WebApp. First I rebooted this and that was the mistake - no connection any more to my Zigbee sensors. So I tried to debug with zhark. At the start of the zshark I got the message to update the firmware. So I did this and I could capture the zigbee. (a lot of FCS Bad checksum, but the sensors tried to communicate :slight_smile: ). This shows me, that the devices works. After that I wanted to switch back to deCONZ App on the Raspberry Pi, but I couldn’t get a success connect. No error message or anything else - just the button get back to a clickable “connect”.
What can I do to fix this?
And is there a tip or procedure how I can verify that these sensors are joined correctly? (Press button and follow the instruction from the sensor is not the problem)

Thanks

You need to reflash the stick with the normal firmware :slight_smile:

1 Like

Thanks - I did it and changed add the stick to iobroker directly.

Hi,

i have the same issue exept my conbee2 was allready in the last firmware before using Zshark, does it mean at each time i use zsahrk we have to flash the conbee again?

Yes that is correct.

Ok Thanks for your reply

I’ve just had a similar problem I installed ZSHARK. I mistakenly clicked ‘OK’ on a dialog that said that something was missing / not present on the device firmware and that it needed to add / install something to the firmware on my ConBee device. I didn’t get any errors but I didn’t know enough about ZShark to know what to do next.

So I closed ZShark and reopened deCONZ but is failed to connect to my ConBee II device.
Thinking that the firmware had become corrupted I attempted to flash firmware onto the device using
the following as my first step.
GCFFlasher -d COM7 -f …\firmware\deCONZ_Rpi_0x26400500.bin.GCF
( where COM7 is the port for ConBee II)

but I get an error writing the flash image.
GCFFlasher V3_17 (c) dresden elektronik ingenieurtechnik gmbh
Reboot device COM7 (ConBee II)
deCONZ firmware version 31000700
R21B18 Bootloader
Vers: 2.07
build: Jun 17 2019
flashing 127650 bytes: |=
dev: ERROR writing image (15 ms)

I tried several times and even re-aquired the firmware file from the deCONZ site
But same error each time. I decided to opt to Even though the first step failed, I opted to go on to the second step and flash the ‘ConbeeII’ file

GCFFlasher -d COM7 -f …\firmware\deCONZ_ConBeeII_0x26780700.bin.GCF

This appears to succeed ok

GCFFlasher V3_17 (c) dresden elektronik ingenieurtechnik gmbh
Reboot device COM7 (ConBee II)
R21B18 Bootloader
Vers: 2.07
build: Jun 17 2019
unlock! (101 ms)
flashing 163230 bytes: |==============================|
verify: .
SUCCESS
Wait 10 seconds until application starts

I opened deCONZ and it successfully connected to my ConBee II device, and surprisingly, but thankfully my Zigbee network was still there, through 2 nodes which were for devices which I added to the network after the last time I created a backup in Phoscon didn’t show connection lines back to the coordinator. After several minutes one of these (an open/close sensor) did reattach to the network, but the other isn’t attaching (REST AI confirms that it is unreachable). My have to reset device and re-add it in Phoscon).

Anyway I’m taking it as a lesson and I’m not going back to use ZShark any time soon.