Using RaspBee on an Odroid N2+

I would like to migrate my whole setup from a Raspberry Pi to an Odroid N2+. The question is if there is any chance to use a RaspBee on an Odroid N2+.

Comparing the GPIO pins of the Odroid with the one from a Raspberry is quite encouraging, both have a very similar layout at the first 12 pins. Especially 5V, 3.3V, GND, UARR TX and UART RX are at the same pins.

The serial connection to GPIOs 8 and 10 is working, I successfully connected to it with an USB UART from another host and could exchange data between the two via the serial connection. The serial device at the Odroid bound to the GPIOs is at /dev/ttyAML1.

However deconz and GCFFlasher_internal do not seem to find the RaspBee connected to the GPIOs of the Odroid. I tried with GCFFlasher_internal -l, GCFFlasher_internal -l -d /dev/ttyAML1. I also tried symlinking /dev/ttyUSB0 to /dev/ttyAML1.

I also tried to start deCONZ with DECONZ_DEVICE=/dev/ttyAML1, also no luck.

Anything else I could try?

One solution would be of course to use a Conbee instead of a RaspBee. That actually works, I have tried it. However it would be nicer to use the RaspBee as it would then be in the box and not a USB dongle attached to it.

Any ideas?

For deCONZ you might try with command line parameter --dev=/dev/ttyAML1, note that the device file needs to be accessible for read/write by the user running deCONZ.

The GCFFlasher 4 likely does fail as well but I think with a small addition the different path should work as well.

Indeed that works. Thank you very much.

By “small addition” you mean patching the source code?

What I am currently observing is

odroidn2:~:# GCFFlasher_internal -l -x 3
GCFFlasher V3_17 (c) dresden elektronik ingenieurtechnik gmbh
12:32:04:318 ls dev: /dev/ttyAML0 (0x0000/0x0000) sn:
12:32:04:318 ls dev: /dev/ttyAML1 (0x0000/0x0000) sn:
Path             | Vendor | Product | Serial     | Type

The issue with GCFFlasher is not that importend. When I have to flash it I can still mount it on a Raspberry for that.

Glad that the --dev parameter works. I’ve added the /dev/ttyAMLx support to GCFFlasher 4 in commit 23e757

1 Like

what os do you have the odroid runing i have it running trhe latest ubuntu img from odroid repo and i cant get the raspbee setup with deconz for the life of me i have the gpio showing up as ttyS1 on it could you let me know what os you are using and steps i have to go through to get it working cause noothing is working for me rn

I am using Armbian 22.02.1. I can’t give you step by step instructions, sorry. I set it up three months ago. Since then it’s running smoothly and I don’t remember details. This is the systemd service file I am using.

Description=deCONZ: ZigBee gateway -- REST API
Wants=deconz-init.service deconz-update.service

ExecStart=/usr/bin/deCONZ -platform minimal --http-port=80 --dev=/dev/ttyAML1