Updates to deconz overwrite /lib/systemd/system/ file

Every time there is an update to deconz, I have to manually re-edit the systemd startup file (to put it back on the appropriate http port), then reload the systemd daemon, then restart deconz and restart the service that would normally be running on port 80. If it needs to deposit a new files, calling it deconz.service.new would work.

It would be ideal if local edits to deconz.service were retained (standard for most things).

I posted this in the phoscon app forum but think that is the wrong spot as most other posts are looking for device integration.

Please flag it the next time.

I Think its time for deconz/phoscon developer that they integrate a config file for the ports

You can use an override file for the change stay permanent.

But I m agree with him, need to write something to help.

Thanks. I will try the override, but will fear missing something functional that is added down the road. My primary home automation system runs on port 80, but is configured to start after deconz (dependent on it), so updates to deconz are currently a challenge as it brings down the system. The “first” time this happened, it took some thinking, but now it is regular process after sudo apt upgrade…

I use deconz on raspberry pi with domoticz
and every time i upgrade deconz , the configuration is overwriten
and so I loose the port configuration (8070)
Is there a way to avoid configuration lost ? something like a predefined variable check ?

Raspberry OS is Linux 5.10


Yes Updates to deconz overwrite /lib/systemd/system/ file - #4 by Smanar

As conclusion , this is not a configuration option…Do you confirm ?

IDK, it’s a configuration option using command line ?