Unable to connect to any device and paring not working after upgrading to 2.17.01 / 26780700

Describe the bug

After upgrading to 2.17.01 / 26780700 (my previous version was 2.12.06 / 26720700) I lost all my lights (are greyed out) and sensors (are unreachable).
Many times when executing an upgrade I need to pair again all devices, like for a lot of deconz users, but this time I’m unable to pair again any device

Steps to reproduce the behavior

Upgrade to 2.17.01 / 26780700, all lost. After a reboot, no change and all device are still unreachable.

Expected behavior

Upgrade procedure works and stops to loose my devices … like a lot of other times :wink:


Screenshot not applicable


  • Host system: Raspberry Pi (Zero W)
  • Running method: Raspbian
  • Firmware version: 26780700
  • deCONZ version: 2.17.01
  • Device: ConBee II
  • Do you use an USB extension cable: yes, microUSB to USB
  • Is there any other USB or serial devices connected to the host system? No

deCONZ Logs

Jul 12 21:42:49 raspberrypi deCONZ[5298]: 21:42:41:227 DB saved in 135 ms
Jul 12 21:42:49 raspberrypi deCONZ[5298]: 21:42:42:130 Daylight now: nauticalDusk, status: 220, daylight: 0, dark: 1
Jul 12 21:42:49 raspberrypi deCONZ[5298]: 21:42:42:130 apsUseExtPanid is 0x0000000000000001 but should be 0, start reconfiguration
Jul 12 21:42:49 raspberrypi deCONZ[5298]: 21:42:42:130 tcAddress is 0x0000000000000000 but should be 0x00212EFFFF078E07, start reconfiguration
Jul 12 21:42:49 raspberrypi deCONZ[5298]: 21:42:42:130 Skip automatic channel change, TODO warn user

Additional context

I have many Ikea bulbs and lights and many Aqara sensor

Your logs indicate some things that are wrong with the network settings.

Can you open deconz and show a screen of the network settings?

In deconz, iirc, you need to select edit and there is network settings.

This screen, right?

I see that the dongle is called “Configuration Tool 1” … before the upgrade if I’m not wrong the name was something like “ConBeeII”

Yes. Not sure what happened there, @de_employees might be willing to help to figure that out.

Either way lets see what happens when you do the following:

  • In deCONZ, click “Leave” on the top (next to in Network in green).
  • Open network settings-
  • change the EXT PAN ID to have all 0 (so the 1 at the end to a 0)
  • Change the TC address to 0x00212EFFFF078E07.

Click “Save” and done. Now click “Join” where you previously clicked the “leave” button.

Ok, these are the network settings now:

but again, I can’t connect to any device and I cannot pair a new device.
I also tried a reboot after the network conf changes.

It is like Mimiix wrote. Somehow your network settings changed completely. The TC Address must be the same as the MAC Address and APS Ext PAN ID must be 0. So thats correct what you did there.

The TC Link Key is also wrong. It always the same (public) key: 0x5a6967426565416c6c69616e63653039
The rest looks ok. You should try to change the key first.

It is possible that your network key or the Channel also changed for whatever reason But perhaps it stayed the same.

If entering the TC Link Key does not work to get your nodes back you can try to load a backup in the phoscon app (if you have one) or to revert to your last working network settings. There is a hidden menu in the Phoscon App when you (ALT+ left click) at the “Advanced Settings” Icon at the Gateway Settings page.

That said… the question is why the network settings changed (during the update). Can you share any other information what you did when this error happened?

Ok, now I can add new devices… but I need to pair again all the lights :frowning:
The need for a re-pair is really too frequent in deConz, at least in my setup.

This is the upgrade procedure I follow:

  • download the new raspian-deb package
  • apt install ./the-package.deb
  • systemctl restart deconz
  • access to phoscon web app
  • click on the upgrade button for the ConBee II device
  • wait (I also watch the flasher tool process end in process list)

My 2 cents: I’ve seen this happen when people use Phoscon to update the firmware. Theres 3 outcomes if you do it with Phoscon:

  • Firmware corupted, it keeps rebooting > Re-flash fixes it
  • Network settings get screwd over > Manually adjusting
  • It succeeds.

@faxioman corrupt network settings don’t require a re-pair. Is the Channel the same as the old one? Can you share some more logs? in #deconz you can find out how.

@Mimiix yes, I never change the channel … in my setup after an upgrade generating the problem, I always need to re-pair all my devices. Restoring a working backup or reverting the network configuration never solved the problem, and I always need to perform a re-pair (searching in github issues really a lot of users, for different problems, are required to a new re-pair :man_shrugging:)
I re-enable the log and I’ll attach it to this thread

Here’s the log:


And no error message when doing that ?
You can take a look in the backup file, it s an archive, inside you have a deconz.conf file, it s a text file, you need to have your network configuration inside.

No error, and it’s perfectly understandable: I never lost my network configuration, I can see all my devices. Simply, I can’t reach them until a re-pair.
Take a look at this screenshot:

If I load one of these network configurations, I always have my conf back … but the devices are always unreachable.

The id 3 of the list has appeared after the network configuration changes suggested by @Mimiix and @ChrisHae

A short update: It’s true that I need to re-pair all my light devices… but I see that all sensors are already paired, no need to a re-pair for them :thinking:
It’s worth noting (?) that ALL my lights are from Ikea.

Logs look better.

What happens if you power cycle the lights?

When something changes in the network configuration then the devices are not longer reachable. On the screenshot the pan id changed during the last update. But a Pan Id of 0x0000 is rather unusual.

We have to investigate this problem further. I would recommend to always create a backup file before updating deCONZ or firmware.

Perhaps it can take some minutes until your devices become reachable again after restoring your config. Enable Light search and power cycle your lights can help them to come back.

@ChrisHae I wait several hours, but my lights are never reachable, until a re-pair.
@Mimiix after a power cycle, the lights are still unreachable… but If I start the search procedure, after the power cycle, they are all found and joined.

If I start the search procedure, without power cycle, lights are still unreachable.

The next week I’ll try to change and then restore the network key in a zigbee2mqtt compliant device, and I’m curious to see the behaviour of the Ikea lights: maybe there some issue with those devices.

Well, that’s better then a re-pair, right?

Wondering what’s causing that @ChrisHae.

I would say the bulbs that lost connection are searching for a network with their corresponding network settings. Power Cycle the bulbs probably triggers that search faster.