MS-105Z integration broken


Using Conbee with latest firmware 2021-12:

MS-105Z (TS0601__TZE200_la2c2uo9)
Using Home Assistant with DeConz (or Zigbee2Mqtt, or ZHA) : pairing works, reports well On/Off status via ConBee OK, but doesn’t respond to commands sent from Home Assistant. Look like integration is broken.

(with a flashed CC2530 / CC2531, MS-105Z works okay, both ways).

Thank you for your help.

I have one too. It work without problem, but as all tuya device, you probably need 2 inclusions
Look at the json as “type”, I thing you have “smart plug”, and you need to have “dimmable light”. Can be repared at restart too.

PS: this working mode is for use with deconz, not the same working mode for Z2M or ZHA.

I’m new to deCONZ. Actually I would have liked it better to work with ZHA – again MS-105Z not responding to commands with ConBee, but working okay with CS2530/CC2531.

I’m trying to change the type to “Dimmable light” with Postman, but it looks like I don’t have the permissions.

The json as it is now:
“etag”: “475006c5a159c39ed1a6731f694da2d2”,
“hascolor”: false,
“lastannounced”: null,
“lastseen”: “2021-12-06T11:41Z”,
“manufacturername”: “Unknown”,
“modelid”: null,
“name”: “Smart plug 3”,
“state”: {
“alert”: “none”,
“on”: true,
“reachable”: true
“swversion”: null,
“type”: “Smart plug”,
“uniqueid”: “cc:86:ec:ff:fe:0f:a4:77-01”

According to post deconz-rest-plugin/issues/5152, I should have these parts as:
“manufacturername”: “_TZE200_la2c2uo9”,
“modelid”: “TS0601”,

Here is the screenshot of what I’m trying to achieve with Postman.

Your URL is totally wrong.

With the HA addon, you need to map the ports and use that.

Using the same URL, GET commands work fine.

No ^^, don’t loose your time with the API, juste remake the inclusion without deleting it, up you have the good type, If it realy don’t work

  • Set phoscon in permit join
  • Read Basic attribute on deconz (Cluster 0x0000)

Can try too with deleting it, but on my side have worked without.

Else I can share my ddf file, but not sure your deconz version can use it ?

I’m using Phoscon within Home Assistant (hassio), I’m not sure how to do that.

I deleted the device and did again a pairing – I guess this is what you call inclusion. And then I did another pairing. That helped a bit because I now have the model and manufacturer.
“etag”: “090418e173b11072c09cf398bd8bc979”,
“hascolor”: false,
“lastannounced”: “2021-12-07T08:33:59Z”,
“lastseen”: “2021-12-07T08:33Z”,
“manufacturername”: “_TZE200_la2c2uo9”,
“modelid”: “TS0601”,
“name”: “Smart plug 4”,
“state”: {
“alert”: “none”,
“on”: true,
“reachable”: true
“swversion”: null,
“type”: “Smart plug”,
“uniqueid”: “cc:86:ec:ff:fe:0f:a4:77-01”
But the type remains to smart plug.

Now I’ve tried the other method:

  • I do a permit join in phoscon
  • Go to deconz (again, this is part of the HA addon)
  • Go to the cluster info of my device (smart plug 4) and put the cursor on “Basic Device Setting”
  • Put my device in pairing mode
  • Click on the read button

Nothing seems to be happening – i.e. the device keeps beeping…

My deconz version is v2.12.6

When using postman with a PUT { “type”: “Dimmable light” }, I’m getting this response:

“error”: {
“address”: “/lights/4”,
“description”: “method, PUT, not available for resource, /lights/4”,
“type”: 4

It also appears that ddf files are not possible on HA (source: deconz-rest-plugin/issues/5152).

Is there a way I could pair them on a e.g. Windows install and migrate the database to hassio? My problem is that I have 50 dimmers to pair…

No you can’t update yourself the type, but deconz is able to update it (at least is phoscon is still in permit join, “add new light”)
Try to select the node in deconz and press the key L, the device will make a leave/rejoin and I think the usefull code part will be trigered again to update it.

I do a permit join in phoscon
Go to deconz (again, this is part of the HA addon)
Go to the cluster info of my device (smart plug 4) and put the cursor on “Basic Device Setting”
Put my device in pairing mode
Click on the read button

You can skip the part “Put my device in pairing mode”, if the device is already in the network (visible on deconz)

And have you tried with making 2 inclusions, without deleting the device ?

Yes, I actually made several inclusions… With no result. And doing a Leave / Join in the deconz app is not giving any result. It’s still seen as a Fairy Light and not a Dimmable Light.

I’m not sure what to do next.

I’m at loss, what you do suggest to debug / fix the problem further? knowing that integration with a flashed CC2530 / CC2531 works perfectly – the problem is obviously with the Conbee firmware…

@de_employees Can we please be more pro-active in reading along?

Sorry, what did I miss?

I’m asking @de_employees (Dresden Elektronik’s) people to tag along and answer :slight_smile:

Thank you!

Do you have access to the deCONZ GUI via VNC in HA.
Here a screenshot of the device endpoints would be interesting (by clicking on the second circle on the right side of the node).

I would have assumed that as a Smart Plug this device should be working generically, but with Tuya you never know.

Info: The next stable version deCONZ update available in HA is scheduled around mid December, here DDF capabilities are included to make easier changes for this type of devices.