Most ZHASwitch stopped reporting via REST API / Websocket


something strange happend for me: I changed absolutly nothing but on the 3rd october most(!) of my ZHASwitches (mostly IKEA, but even the Ubisys J1) stopped reportig via REST API and Websocket. I already changed batteries in some but as even the hard wired Ubisys ones stopped…

All of my TRADFRI remote control, TRADFRI on/off switch and TRADFRI open/close and my (2) J1 (5502) are affected. Only the Ikea STYRBAR and the Hue dimmer switch still report.

I can tell the Ikea und Ubisys Switched do indeed still work - because they trigger the lights / blinds I added to their Switch Groups.

I already restarted deCONZ. It was running since 09-21 and it looke like the issue appeard on 10-03:

  "state": {
    "buttonevent": 2003,
    "lastupdated": "2023-10-03T14:58:53.808"

… this is the last time I heard from one of them.

What can I do to fix that? Every button event that does not works via Switch Group does not work anymore…

I just noticed my (single) Ikea TRADFRI motion sensor does not work since 10-03 anymore, too. It should trigger a light (configured in Phoscon) but does not. All otherr (Aqara, SONOFF) ZHAPresence sensors still work.

  "config": {
    "alert": "select",
    "battery": 74,
    "duration": 122,
    "on": true,
    "reachable": true
  "ep": 1,
  "etag": "0dbc61553afff1a1f79f32b922262520",
  "lastannounced": "2023-09-02T08:41:56Z",
  "lastseen": "2023-10-09T05:49Z",
  "manufacturername": "IKEA of Sweden",
  "modelid": "TRADFRI motion sensor",
  "name": "Bewegungsmelder Garage",
  "state": {
    "lastupdated": "2023-10-03T13:01:02.583",
    "presence": false
  "swversion": "2.0.022",
  "type": "ZHAPresence",
  "uniqueid": "ec:1b:bd:ff:fe:9e:b1:67-01-0006"

This is the “INFO_L2” Log when I press a button on one of the affected switches:

09:07:11:280 Websocket send message: {"attr":{"id":"17","lastannounced":null,"lastseen":"2023-10-09T07:07Z","manufacturername":"IKEA of Sweden","modelid":"TRADFRI remote control","name":"FB Büro","swversion":"2.3.014","type":"ZHASwitch","uniqueid":"00:0b:57:ff:fe:95:34:36-01-1000"},"e":"changed","id":"17","r":"sensors","t":"event","uniqueid":"00:0b:57:ff:fe:95:34:36-01-1000"} (ret = 2125372392)

Thats all. No buttonevent

Can anyone provide help for this problem? I have no idea what to do and all my button actions don’t work aymore…

Was the firmware automatically updated?

Indeed odd, so for my understanding the issue didn’t happen after a deCONZ update but out of nowhere?
Since the Zigbee communication seems to work… only a guess could it be that the timestamps are messed up :thinking:

I’m only using the old round Ikea and Xiaomi remotes which work as usual.

Do the nodes in the GUI blink blue when you press a remote button?

No deCONZ update (I updated deCONZ to 2.23.02 in the meantime which changed nothing). No firmware update(s). I just updated the J1 to the new firmware (2.3.0) but that changed nothing, too.

In fact I was not even near a computer for a few days when it happened out of the blue. So I wasn’t even able to login to deCONZ or Phoscon (as the mobile login is broken). And nothing was changed on the raspberry pi.

I just tested one round ikea remote: first time I pressed the button in the middle it blinked blue a few times and then green. Now it just blinks green when I press buttons.

I can read the Power Percentage Remaining without problems. Click “Read” and press a button to wake it up. Reading done - but no button event :frowning:

I found an unused IKEA Remote and tried to pair it. It does not work:

I can see it in deCONZ:


Then I tried to re-pair an existing one without deleting it first. Fails in Phoscon but remains unchanged in deCONZ.

Ok, wow. I could have tried that earler but… I just noticed the Raspberry Pi had an uptime of 380 days. So I rebooted it and everyting worked again. Maybe the Conbee II just needed a power cycle…?

Interesting, perhaps yes but still strange that some things worked some not.
Glad that it works now :+1:

1 Like